0

I recently installed NordVPN on a machine with a dual-boot (Win10 + Ubuntu) and all was good until I tried to uninstall. At the point I lost the ability to connect the internet, not with the WiFi and not with the cable. I had a long exchange of emails with their support team but they didn't help to solve the problem. In the end they just told that the problem is with my OS and they can't help me in any way. They made install and re-install the package a number of times, made me change my DNS servers, disable IPv6 and reset the NetworkManager. I'm not expert so I followed blondly their instructions.

I'm not in the position to simply re-install the OS as I would have done normally, so I hope that someone can help to fix it.

4
  • The tech support from the company who software appears to have caused the problem can not help? Do not see how any one here could, I think it is re install time. Why can you not re install?
    – David
    Jan 24 at 13:20
  • Yeah, can you believe it.. how shitty is that service?? Anyway why do you think no one could? I just think that people in customer service are not that much into Linux - I see there are quite a lot of questions here about connections problems that they are supposed to solve.. Edit: It's a long story, trust me if I say that I can't re install.. :)
    – khayozu
    Jan 25 at 17:09
  • simple question did you reboot the system after that?
    – JoKeR
    Jan 25 at 21:08
  • "I had a long exchange of emails with their support team but they didn't help to solve the problem." -- Only a thousand times... :)
    – khayozu
    Jan 26 at 15:18
1

Do the following:

sudo killall nordvpnd

sudo nano /etc/resolv.conf

add/replace:

nameserver 8.8.8.8
nameserver 8.8.4.4

If you can't make the changes:

Overwrite the permission

sudo chattr -i -a '/etc/resolv.conf'

sudo chmod ugo+w '/etc/resolv.conf'

Then

sudo systemctl restart NetworkManager.service

now you can check with ping -c2 google.com

P.S.

I have used NordVPN in the past and they like to change the permissions of resolv.conf for some reason and after update or un-installation it messes up with the resolv.conf

11
  • Usually the reboot should have fixed it, if not try the above.
    – JoKeR
    Jan 25 at 21:26
  • I would only add maybe remove the internet connection in nm-connection-editor (you have not said if ethernet or wireless though). and unplug, replug the cable back in to pick up a new connection. " I'm not expert so I followed blondly their instructions." Of course blondly, it is Nordic VPN. /joke . I was very happy with their service and help responses.
    – pierrely
    Jan 26 at 6:07
  • no need to unplug the cable you can reload the network interface but if the permission of resolv.conf has been overwritten by NordVPN it won't help
    – JoKeR
    Jan 26 at 8:22
  • Ok, I'll try and let you know! Thanks!!
    – khayozu
    Jan 26 at 15:19
  • Si I tried what you wrote. I had to overwrite the permission, replaced the nameserver and restarted the NetworkManager but still nothing, I've tried to give again the command "sudo nano /etc/resolv.conf" and this time it reads: # Generated by NetworkManager nameserver 127.0.0.53 Rebooted again but still no connection... I am lost..
    – khayozu
    Jan 27 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.