1

What was done:
Had taken a backup of sda7 using dd (sda7 was around 100GB in size).
Formatted the disk.
Used GParted from a LiveUSB to create new partitions, but this time, created sda7 with 355GB.
Wrote the backup of sda7 to the newly created partition using dd.
Used grub tools to install grub and be able to boot.

The problem:
enter image description here
sda7 is showing a grey area (circled in red) which I assume isn't recognized by Ubuntu as writable area.
enter image description here So once I finish using up the white area in sda7, I assume I won't be allowed to use more than the 96.2GB shown.

I tried resizing the partition using the handle (red arrow), but I couldn't resize it. enter image description here

Is there any way I can make the grey area get recognized?

1

You need to resize the filesystem to fill the partition:

sudo resize2fs -p /dev/sda7

This will work while booted into the OS. Take a look at man resize2fs for further details.

2
  • Similar to this answer, I often print out my partition table from parted before writing a partition with dd. Then I go back in and re-write the partition table like it was originally. However, this sounds easier. – notorious.dds Jan 23 at 18:25
  • Worked! Wow, that was super-simple. – Nav Jan 24 at 4:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.