11

I have just updated to 18.04, and cannot right-click and get the little menu to select "Always on top" for Firefox/Chrome, but I can do so for the terminal, pdfs, etc. (along with other things like Minimize, Maximize, Move, etc.) It appears to be a known issue (https://discourse.ubuntubudgie.org/t/18-04-always-on-top-right-click-menu-issues/580), but does not, as far as I can see, have a known fix... Thoughts appreciated.

Thanks.

3 Answers 3

22

Although answer by Levente works, but I find it too slow to be used. So here is a better alternative (based on the same fundamental).

Use super + right click on the top bar (instead of just right click) and you can see the always on top option.

This option will be accessible in non-maximised state.

Note : I discovered the method in my answer while trying Levente's method, so partial credit goes to him too.

Update 1: "The super + right click combination works in any portion of the window". Thanks to Julian Alarcon for pointing this out

3
  • 2
    Works for me too!
    – Levente
    Apr 2, 2021 at 0:21
  • 7
    The super + right click combination works in any portion of all the Firefox window, not only in the top bar. Apr 26, 2021 at 14:30
  • 2
    super key is sometimes called Windows key
    – galath
    Jan 13, 2022 at 11:32
12

I am on 20.04, and have only Firefox installed: I could experiment only with that, and not with Chrome.

I could reproduce your issue: when I right-click anywhere on Firefox's window or on the top window decoration, the "Always on top" option is missing, along with other common window-manager related options.

Yet, they can be accessed; the only condition is that the window needs to be in non-maximized state.

When one moves the mouse cursor along the edges of a (not maximized) window, the cursor changes to indicate that a click-drag along that edge would start resizing the window.

When the cursor is in this resizing mode, a right-click reveals the original window-manager context menu, along with the "Always on top" option, which even works as intended.

Bonus:

The size of the drag-to-resize area is configurable:

gsettings set org.gnome.mutter draggable-border-width 20

This will give you a 20px range along the window edges to expose the desired resizing mode.

2
  • This does the trick, cheers! Thanks very much. Also it seems it's not a problem on Unity, which I'd not realised wasn't the default.
    – Fintan
    Jan 23, 2021 at 9:31
  • the bonus was so cool Apr 4, 2021 at 13:23
2

Using Alt + Space is the way to go.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .