I have Dell 5110n laptop that belongs to 2011 so it won't support UEFI at all. Now I just wanna know how can I:

  1. Make bootable USB flash for JUST Legacy mode
  2. Force Ubuntu to install only in Legacy mode

I want install Ubuntu dual boot with Windows 10 (Version 1709 build 16299.461).

I read this question and also deleted EFI directory but the Ubuntu still doesn't show Keyboard icon that shows it loaded in UEFI mode.

and if I don't make EFI partition it gives me the below error: Force Ubuntu to boot just in Legacy

also when I make an EFI partition it will gives me this error at the end and will fail the installation process:

Install Ubuntu Dell 5110n Legacy mode

P.S: I know I should boot my USB in just Legacy mode because my Windows installed in Legacy mode too. But I don't know how should I do that. Either make bootable USB (with Rufus or Universal USB installer) or just force Ubuntu to boot in Legacy. P.S: My bios doesn't have any "Fast boot" or "Secure boot" option or any way to boot in UEFI.

so can you please give me a hand? Thanks in advance

  • Thank you for your replying but that picture wasn't mine. Would you please check the picture again? I just took and uploaded mine. I have two HDD. one Samsung SSD and another Hitachi HDD. So I'm sure I installed Win 10 in Legacy mode because when I juse "msinfo32" it gives me "Legacy".
    – GameO7er
    Commented Jan 22, 2021 at 19:40
  • Yes, that pic is a legacy dos disk. The Ubuntu ISO boots either way, depending upon how your machine's BIOS/UEFI settings are. Unfortunately, each vendor may use different terminology for this. CSM mode is compatibility or legacy, You might have a choice of prefering legacy over UEFI. Maybe all you have is Win7 vs. other. Setting the BIOS to boot legacy should be a lot easier than recreating the ISO without the UEFI bootloaders.
    – ubfan1
    Commented Jan 22, 2021 at 19:54
  • Rufus creates BIOS only or UEFI only flash drive installer. This is UEFI: askubuntu.com/questions/1278772/… You want BIOS and CSM mode. CSM - UEFI Compatibility Support Module (CSM), which emulates a BIOS mode, only available with secure boot off. This currently shows Rufus BIOS only screen. ubuntu.com/tutorials/… Since mode installs are now to newer systems with UEFI, it may change in future.
    – oldfred
    Commented Jan 22, 2021 at 22:19
  • Thank you for your time. I tested with multiple version of Rufus randomly but none of them had only "Legacy" or only "Bios" item so I used latest version and so on... Rufus 2.10.973 - Rufus 3.1.1320 - as I told my Bios doesn't have any "Secure boot" or "Fast boot" to turn it off. so I can't turn them off. so do you know any other way to boot in LEGACY? or make a USB bootable just in LEGACY? Thanks in advance
    – GameO7er
    Commented Jan 23, 2021 at 9:09
  • when ubuntu ask you to reboot or to proceed with live-session. choose to proceed and the try do install grub on /dev/sda . `sudo grub-install /dev/sda' in live-session. this was for me the only way, for bios mode.
    – nobody
    Commented Jan 23, 2021 at 12:14

2 Answers 2


I have the same issue on a pre-uefi GA-EX58-UD4P mb with award bios. I get the fatal error installing ubuntu 20.04 on a new SSD. A live boot-repair usb also fails to install boot loader due to the session having booted in "compatibility" mode. I did find a work around by shutting down after a "fatal error" install, then plugging in and booted an old ubuntu hdd. Then did "sudo update-grub". Shut down + unplugged the old hdd. Booted the new install and the link to it appeared in the grub bootloader screen. I suspect using a live usb session to mount the disk the failed install is located on then using "sudo update-grub" might have worked too.


The problem has been solved. Here is the solution for those have same problem like me:

The reason of getting error was having two HDD. The old HDD, and new one is SSD. So the Bootloader was stored on old HDD meanwhile the Ubuntu installed on SSD and when I was trying to fix grub, it was trying to fix old HDD. So my friend fixed Bootloader with EasyBCD app and then problem solved because he set Bootloader to loading from SSD.

Hope this help many people.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .