1

I use Wireguard to make a LAN VPN connection to my server... I managed to configure the server and my client properly and the VPN works fine on most internet networks that I access with my computer. However, there's a public internet connection close to my house that the VPN connection with Wireguard doesn't work and I have no idea why. At first, I thought it could be something wrong with that public internet and there could be something blocking the connection that is beyond my control, but then I made a client configuration on my Android phone using the Wireguard app and the VPN worked properly while connected on that public internet, so now I think there's something wrong with Ubuntu 20.04 Wireguard client (I haven't tested it on Windows). When I run wg show I see the connection as if it was made:

interface: myconnectionname
  public key: serverkey
  private key: (hidden)
  listening port: serverport

peer: mypublickey
  endpoint: serverip:serverport
  allowed ips: 10.15.0.0/24

On any other internet connection that I try to connect, this VPN works properly. So, is there any way of checking what's going wrong so I can fix it?

2
  • Any question should always include the version of Ubuntu you are using. What version is it?
    – David
    Jan 23, 2021 at 6:30
  • 1
    @David I did it... "now I think there's something wrong with Ubuntu 20.04 Wireguard client". It's on Ubuntu 20.04.
    – raylight
    Jan 23, 2021 at 15:28

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.