0

I have an HP Elitedesk 800 g1 sff with an integrated Intel Xeon E3-1200 V3/4th Gen graphics card. I've been using Ubuntu on this system for years without problems, but am now facing an awkward situation:

  • I have Ubuntu 20.04 on a MBR disk (2TB) and it works flawlessly
  • I clean installed 20.04 on a GPT disk (3TB), and the system is responsive until after login - I can enter username and password, select to restart etc. But when I'm logged in, the screen starts flickering and nothing works. I can only go to console and reboot.
  • If I run Ubuntu in recovery mode (640*480), everything works.

Considering that the same version (20.04) on the same system works flawlessly with MBR but doesn't work past login on the GPT/UEFI install, I'm assuming that's where the problem lies. I updated the BIOS to the latest version, with no results.

I tried tinkering with the graphics drivers but to no avail, so now I'm back to a clean install not knowing what to do.

Any suggestion?

4
  • Lets see details, use ppa version with your live installer (2nd option) or any working install, not Boot-Repair ISO: Please copy & paste the pastebin link to the Boot-info summary report ( do not post report), do not run the auto fix till reviewed. help.ubuntu.com/community/Boot-Repair – oldfred Jan 22 at 15:01
  • Thanks. In the meantime I had to resort to install Debian because I couldn't afford to have the machine down. Do you need the boot-info related to the non-working setup (i.e. I should reinstall 20.04 and then run Boot Repair)? – Gianfranco Jan 24 at 18:34
  • I also think it is graphic issue. The Boot-Repair report was just to confirm install looked normal & does not show anything in boot after loading grub. With newer Ubuntu you now have "safe boot" and the option to install the proprietary nVidia driver during install. Before & probably still with Debian, you need nomodeset to boot live installer & first boot or until you manually install nVidia driver from system settings. – oldfred Jan 24 at 19:36
  • What is beyond me is why, with the same PC, 1) the new install doesn't work, 2) the previous install of 20.04 works fine, 3) the 20.04 live cd works fine, 4) the 20.10 live is unusable. I'd really like to go back to Ubuntu (using it since 2004 and still using it on my other machines). Do you think using Nvidia drivers on an Intel Graphics card could help? – Gianfranco Jan 25 at 11:23
0

I think I found the solution - it's a kernel bug: https://bugzilla.redhat.com/show_bug.cgi?id=1843274

Apparently, it's solved in kernel-5.11 rc4. So if you're affected by this bug, you should either downgrade the kernel or wait for the new kernel to be made public (as of today, the latest kernel available for Ubuntu appears to be v5.10.10).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.