1
./ac_client(+0xe983e) [0x55dac9b8c83e]
/lib/x86_64-linux-gnu/libc.so.6(+0x46210) [0x7f302b46f210]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x3b5863) [0x7f3027e88863]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x123b00) [0x7f3027bf6b00]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x2aed16) [0x7f3027d81d16]
./ac_client(+0x83a87) [0x55dac9b26a87]
./ac_client(+0x8b7e1) [0x55dac9b2e7e1]
./ac_client(+0x8c252) [0x55dac9b2f252]
./ac_client(main+0x10b5) [0x55dac9b13835]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf3) [0x7f302b4500b3]
./ac_client(+0x1d64e) [0x55dac9ac064e]
AssaultCube error (11) ()
OpenAL Error (A004): invalid operation, line 359
AL lib: (EE) alc_cleanup: 1 device not closed

This error is registered. The game crashes

4
  • Have you tried to reboot with previous kernel version? If not - reboot computer, press <Shift>, in GRUB go to advanced options, select previous kernel version, boot then retry launching AssaultCube. – N0rbert Jan 22 at 8:17
  • I've rebooted with previous kernel (5.8.0-38) ,the game still crashes. The game used to run smoothly with kernel 5.4 – Regern Faraja Jan 22 at 9:01
  • 2
    There are known current regressions with the 5.8.0 kernel. DO NOT use Kernel 5.8.0 if you are experiencing issues at this time, and use the 5.4.X kernel as is suggested in N0rbert's answer. – Thomas Ward Jan 28 at 21:52
  • I've tried it out myself .. we're working on the 1.3 release ATM .. a DEBUG build was able to run, a regular build crashes as posted above. I'll investigate some more! – flowtron May 20 at 10:04
1

You have to do the following:

  1. Reboot the system into GRUB and hit Shift, then select Advanced options for Ubuntu line, and then choose line with oldest Linux 5.4 and hit Enter to boot system using it.

  2. Login to the system, open terminal to execute commands below to get General Availability (GA) 5.4 kernel back:

    sudo apt-get purge linux-generic-hwe-20.04 linux-image-generic-hwe-20.04 \
    linux-headers-generic-hwe-20.04 "linux-*5.8*"
    
    sudo apt-get update
    sudo apt-get install linux-generic linux-image-generic linux-headers-generic
    
  3. Reboot to use latest GA Linux 5.4 kernel version.


Note: to revert the changes and to use 5.8 HWE kernel execute sudo apt-get install linux-generic-hwe-20.04 linux-image-generic-hwe-20.04 linux-headers-generic-hwe-20.04 .

0

The client does not appear to run properly in this environment; you can get it started by using the --loadmap argument on the command-line like so:

./assaultcube.sh -t -w1024 -h768 --loadmap=ac_mines

Other maps that work include ac_douze - good old makkE maps :-) - ac_werk for instance reliably crashes the client. So - this isn't something you can use for online playing; the release is from 2013 and hence didn't have the newest drivers and library versions to bugfix against.

The AssaultCube project is currently preparing for the release of version 1.3 the ALPHA2 of which is running smoothly on my system!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.