After installing Ubuntu 12.04LTS 64bit I am unable to launch Google Earth.

When I try to launch in terminal I get the following:

pst007x@pst007x-Serval-Professional:~$ cd /opt/google/earth/free
pst007x@pst007x-Serval-Professional:/opt/google/earth/free$ ./googleearth.bin
bash: ./googleearth.bin: No such file or directory

If I use Nautilus and navigate to "/opt/google/earth/free" "googleearth.bin" is there.


Tried creating a new profile and deleting my old profile, purging my system of Googleearth, used Janiter to remove all other references too, re-installed from fresh download, but same issue..

So how is it possible that a successful installation, with all the dependencies installed, and the googleearth.bin file there, confirmed, but will not launch, with the error "bash: ./googleearth.bin: No such file or directory"

  • Google earth should install itself into this path: '/opt/google/earth/free'. Please check if it is there and try to start 'googleearth' from that directory.
    – Thomas
    Commented May 3, 2012 at 19:58
  • @Thomas "/opt/google/earth/free" the GOOGLEEARTH files are there, but do not run, when I launch in terminal I get the message file not found, but the file is there when I navigate to the folder. It's a strange one. Thanks
    – pst007x
    Commented May 3, 2012 at 22:09
  • Please try this: ldd /opt/google/earth/free/googleearth-bin. But you are right - a strange one :)
    – Thomas
    Commented May 4, 2012 at 17:58
  • Posted output above, thanks Any ideas? Appreciated..
    – pst007x
    Commented May 8, 2012 at 11:38
  • 3
    ... just a quick query - why are you downloading the deb package from google rather than installing & make from the repository version of google-earth?
    – fossfreedom
    Commented May 8, 2012 at 11:43

4 Answers 4


This is the method I used to install Google Earth on my 64bit Laptop and it worked perfectly

Firstly, I made sure I had all my media codecs installed then followed these instructions:

If you are running a 64-bit version of Ubuntu 12.04 then you will also need:

sudo apt-get install ia32-libs

To install Google Earth copy and paste the following command in the Terminal Window.

sudo apt-get install lsb-core

Google Earth 6.2 Latest Upgraded Version:

Download Google Earth 6.2 from here

Select either: 32 bit .deb (For Debian/Ubuntu) or 64 bit .deb (For Debian/Ubuntu)

depending on your PC architecture and install in Software Center.

That's It

I dont see any mention in your question or subsequent answer about ia32-libs. Have you installed this. You need this for 64bit also.

  • I installed the 64bit version, however the ia32-libs is also installed and lsb-core. Thanks
    – pst007x
    Commented May 11, 2012 at 10:33
  • Glad your sorted, if my answer resolved your issue, please accept it as the correct answer so others can benefit Commented May 11, 2012 at 10:36
  • 1
    Sorry dude, mis-understood... Still not working, I still get the message ... bash: ./googleearth.bin: No such file or directory ...Even though all the correct files are installed... I am confused :-/
    – pst007x
    Commented May 11, 2012 at 10:44
  • Version installed is: .... still no joy.. Thanks
    – pst007x
    Commented May 11, 2012 at 10:46
  • 1
    Yes, i tend to use Synaptic, but also tried Software Centre and GDebi installer. However, the installation is fine, always successful, but when I try to run, the file is not found. This is even using Terminal to launch, if I navigate using Nautilus to the folder the file is there but still will not launch 'file not found' when run... So I am confused.. Thanks
    – pst007x
    Commented May 13, 2012 at 16:25


I am using Ubuntu 64bit version and I was trying to logically install Google-Earth 64bit version... but there must be a bug in the installer..

So after a complete purge I installed the 32bit version and it worked!


I had got very similar problem on Ubuntu 12.10 64bit. I successfully installed google-earth-stable_current_amd64.deb. But google-earth didn’t start. Just showed splash screen. I tried terminal with error: Google Earth has caught signal 11 Main problem is your graphic card drivers only. Also you must install ia32-libs,lsb-core packages. But this did not solve the problem with signal 11 crash.

I then installed AMD ATI drivers and this solved my problem.

My card: 01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV770 [Radeon HD 4850]

Type the following in terminal for Radeon HD 2xxx, 3xxx a 4xxx :

  • sudo add-apt-repository ppa:makson96/fglrx
  • sudo apt-get update
  • sudo apt-get upgrade
  • sudo apt-get install fglrx-legacy
  • sudo reboot

install this first:

sudo apt-get install lsb-core msttcorefonts  

then download the G.E. .deb file from google

then open the file in ubuntu sofware center and install..

it works fine on me.

  • Strange, that is what I have done. I always had it working fine on previous versions. It looks like a bug in my install. I really do not want to install again, it is a working laptop. Any ideas why terminal will say that the file is not found, but it is there and install was successful. An icon even appears in my launcher... At the moment I have used Win7 in a VM to run it, but not the best solution..
    – pst007x
    Commented May 8, 2012 at 11:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .