I have a new instalation on a new Dell laptop (i7 8GB RAM). I find my network and successfully connect to it, but then when I open a browser, it acts like I don't have an internet connection. Please help.

  • The only way i managed to connect to Internet was by removing all security methods (and by plugging the Ethernet cable). Thats weird problem... – Martin May 3 '12 at 20:16

I always find with network issues you want to try pinging in one order or the other:

ping localhost


ping you local gateway (normally

    ping 192.168.X.X

ping an IP external to your local netowrk (Google public DNS)


ping a domain to see if you can resolve a domain

    ping google.com

depending on which of these work it will help you track down the problem, if you can't ping your router your network isn't up as advised, if you can ping further then you know you're looking in the wrong place.


Try changing the security method of your router from WEP to WPA/WPA2. I had this issue but after changing the security the wireless connection worked fine for me. (Yes this solution aaplies to you if you are using WEP security)

I got idea of changing the security method from this link - Wireless with WEP extremely slow on an Acer Timeline 4810T with a Centrino Wireless-N 1000 and it worked


  • Didn't work for me :\ – Martin May 3 '12 at 19:33

protected by Community Jun 25 '12 at 11:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.