I can only enter my password with the keyboard and this is what I see after I login

image of black screen with dock with grey icons

If I try to switch to a terminal with CtrlAlt+F1 I get this
image of completely black screen following Alt+F1

I don't have a clue how to fix this, or if it's even possible to fix this without access to a terminal.

The recovery console does not work either. It opens, but keyboard input doesn't seem to be working for it either.

Anybody had this happened?

Update (next day) Keyboard input lets me do Alt+F2 and invoke a terminal, but I can't change focus to the terminal window that opens. Any tip on how to switch focus (Alt+Tab wont work) to the terminal window.

Maybe looking at this you might have a clue what's going on, maybe there's no window manager loading?

  • Do you have guest additions installed, and hardware-acceleration enabled?
    – labarna
    May 3, 2012 at 19:55
  • when I try to re-install Guest Additions (which I did have installed) I get a Mount Error. I do have both checkboxes for hardware acceleration enabled (VT-x/AMD-V and Nested Paging)
    – Gubatron
    May 4, 2012 at 23:55

3 Answers 3


Have you sanity checked all the basic Virtual Machine configuration settings? That is, try to set the VirtualBox VM settings to something, well, simple?

  1. In General ensure that the Operating System is Linux and Version is Ubuntu or Ubunt-64 as appropriate.
  2. In System use PIIX3 as the chipset. Do not enable EFI.
  3. In Display, only 1 display, naturally. Turn both 3D & 2D accerleration off. I have no idea what to advise on the size of video memory. So, 32 MB? (Seems like way more than adequate, so why not?)
  4. In Audio I always have to use "ICH 97" or I get no sound in Ubuntu. (I have no idea why "Intel HD Audio" om VirtualBox does not work for Ubuntu. I keep intending to ask about that.)

Just as an attempt to see if you can get into any kind of a usable terminal mode, have you tried booting into single user mode?

  1. Select (highlight) the GRUB boot menu entry you wish to use.
  2. Press e to edit the GRUB boot commands for the selected boot menu entry.
  3. Add the kernel boot option single after ro quiet splash on the line near the bottom.
  4. Press either Ctrl+X or F10 to boot using these kernel options.

If you can successfully boot into single user mode, you can then both install the VirtualBox Guest Additions and apply any current 12.04 updates. I suggest that you try doing this.

  1. Begin by installing dkms using

    apt-get update
    apt-get install dkms

    I recommend this for two reasons:

    • Oracle recommends doing this in the Installing the Linux Guest Additions section of their VB manual.
    • I personally have had problems installing the Guest Additions in a VB VM when I did not install dkms. ;-)
  2. Attach the Guest Additions image file to the CD drive of your virtual machine. On my MacBook this image is located at:


    Note: Pressing Shift++G will open a Go To The Folder window in Finder into which you can enter the full path name for the image file.

  3. Mount the your virtual machine's (virtual) CD device:

    mkdir /media/VbAdditionsCD
    mount /dev/cdrom /media/VbAdditionsCD
  4. Run the Guest Additions install:

  5. I would also recommend applying any other current 12.04 updates with:

    apt-get upgrade
    apt-get dist-upgrade

    (It may not help but it is worth a try, no?)

  6. Reboot and let us know what happens

    reboot now

Note: sudo is not required for the commands listed above because when you use single user mode you are root (Mentioning this just in case someone is curious).

Have you looked at any of the logs? Can you can boot the VM from a Live CD? If so, have a look at the VM's /var/log/syslog.

It also occurs to me that since this is happening inside a VirtualBox VM you (also) should look at the logs for the virtual machine to see if anything "pops out" at you.

You could also cut and paste the text of the log into a pastebin, paste.ubuntu.com for example, and then add the link to the pastebin to your question.

VirtualBox Manager with show log highlighted

  • everything is just like you recommend, sanity checks in place.
    – Gubatron
    May 4, 2012 at 14:12

I saw the same symptoms after the 12.04 update. I removed and reinstalled the VBox additions and then did an "apt-get -f install". Both logged in as root booted in single user mode. Remove the "gfxmode $linux_gfx_mode" line in grub if you can't get single user mode to boot.


I also tried the sanity checks as well and those helped me figure out what is wrong. In my case, it was a missing install of "libjpeg8" during upgrade from 11.10. To fix it, here's what I did:

  • Hold SHIFT while booting, choose "previous Linux versions". In that menu, I had the options for Ubuntu, with linux 3.0.0-14, Ubuntu, with linux 3.0.0-12, Ubuntu, with linux 2.6.38-11. I chose -12, which I assume corresponds to 11.10 that I had.
  • Upon booting, I got the same black screen but this time the tiles on the left were operational, so I was able to open a terminal window and click on it so that I could type.

sudo apt-get install libjpeg8

  • Then I removed the vbox guest additions (I had to run this a few times. Each time I ran, uninstaller did something so I tried until uninstaller did not report any change)

sudo sh /media/VBOXADDITIONS_4.1.12_77245/VBoxLinuxAdditions.run uninstall

  • and reinstalled

sudo sh /media/VBOXADDITIONS_4.1.12_77245/VBoxLinuxAdditions.run

Upon reboot, I got a working desktop.

  • FWIW, if you could boot into single user mode you could have also performed the above commands that way. single user mode is, after all, sort of the ancestor of all command lines. ;-) May 6, 2012 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.