1

Hello sorry for the question title, I'll edit later

On a damn Asus netbook model X205TA you can't boot the common USB live made with e.g. unetbootin or rufus

GOAL: wipe the existing Windows 10 32bit and install "Ubuntu Mate 32bit"

PROBLEM: no way to boot from USB with a standard USB live pendrive

I have found a first documentation on https://chanon.info/install-lubuntu-15-10-on-asus-x205ta-bing-fd0039bs/1084/ that solved the first issue

The instructions tell to create /EFI/BOOT path on the pendrive root and to copy in /EFI/BOOT the file downloaded from https://github.com/jfwells/linux-asus-t100ta/blob/master/boot/bootia32.efi?raw=true

Cool, after this, finally I had the grub> prompt

in the instructions are the commands to issue at the grub> prompt

and there it comes the setup string

linux /casper/vmlinuz  file=/preseed/ubuntu-mate.seed boot=casper iso-scan/filename=${iso_path} quiet splash ---

but the live pendrive doesn't have the .ISO file, it only has the large

/casper/filesystem.squash

So I tried

set isofile=/casper/filesystem.squash
linux /casper/vmlinuz  file=/preseed/ubuntu-mate.seed boot=casper iso-scan/filename=$isofile quiet splash ---

But I get error

BusyBox u1.27.2 (Ubuntu 1:1.27.2-Zubuntu3.2) built-in shell (ash) 
Enter 'help' for a list of built-in commands.

(initramfs) mount: Mounting /dev/loop1 on //filesystem.squashfs failed: Invalid argument 
Can not mount /dev/loop1 (/cdrom/casper/filesystem.squashfs) on //filesystem.squashfs

So I suspect that this parameter

iso-scan/filename=$isofile (which, given the SET above, translates in =/casper/filesystem.squash)

will be totally different

How should I setup that string before to issue the last two commands?

initrd /casper/initrd.lz
boot

Thank you

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.