0

am trying to install any desk:arm-hf in Ubuntu 20.10 arm64 machine.

because of cross platform I used dpkg for installation.

> > pi@pi-desktop:~/Downloads$ sudo dpkg --force architecture -i anydesk_6.0.1-1_armhf.deb Selecting previously unselected package
> anydesk:armhf. (Reading database ... 136205 files and directories
> currently installed.) Preparing to unpack anydesk_6.0.1-1_armhf.deb
> ... Warning: The unit file, source configuration file or drop-ins of
> anydesk.service changed on disk. Run 'systemctl daemon-reload' to
> reload units. Unpacking anydesk:armhf (6.0.1) ... Setting up
> anydesk:armhf (6.0.1) ... Created symlink
> /etc/systemd/system/multi-user.target.wants/anydesk.service →
> /etc/systemd/system/anydesk.service. Processing triggers for
> gnome-menus (3.36.0-1ubuntu1) ... Processing triggers for
> desktop-file-utils (0.24-1ubuntu4) ... Processing triggers for
> mime-support (3.64ubuntu1) ... Processing triggers for
> hicolor-icon-theme (0.17-2) ...
> 
> anydesk got installed.

but when i tried to open through terminal it shows an error

anydesk: error while loading shared libraries: libpolkit-gobject-1.so.0: cannot open shared object file: No such file or directory

so I tried to install libpolkit-gobject-1.so.0 using aptitiude

pi@pi-desktop:~$ sudo apt-get install libpolkit-gobject-1.so.0
[sudo] password for pi: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libpolkit-gobject-1.so.0
E: Couldn't find any package by glob 'libpolkit-gobject-1.so.0'
E: Couldn't find any package by regex 'libpolkit-gobject-1.so.0'

after refering some forum i tried this

pi@pi-desktop:~$ apt-file list libpolkit-gobject-1-0
libpolkit-gobject-1-0: /usr/lib/aarch64-linux-gnu/libpolkit-gobject-1.so.0
libpolkit-gobject-1-0: /usr/lib/aarch64-linux-gnu/libpolkit-gobject-1.so.0.0.0
libpolkit-gobject-1-0: /usr/share/doc/libpolkit-gobject-1-0/changelog.Debian.gz
libpolkit-gobject-1-0: /usr/share/doc/libpolkit-gobject-1-0/copyright

still am getting same error.how to install libpolkit-gobject-1.so.0 or how to make anydesk to work

1
  • armhf and arm64 are completely different infras. It's looking for the armhf files, NOT the version in your default OS. You can check this by running ldd $(which anydesk) and see what library versions it's actually looking for - chances are it's looking for armhf versions of the so and NOT the arm64 versions.
    – Thomas Ward
    Jan 20, 2021 at 17:59

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy