37

I can't install VMwarePlayer 4.0.3 on Ubuntu 12.04 64Bit. For Version 4.0.2, I found a script that I have to run to patch VMware Player for it to work on my system to properly, and after that I could install 4.0.2.

Is there an similar solution for Version 4.0.3?

  • on VMware Kernel Module Updater -Dialog I get the Error on Compiling "Virtual Network Device" and an Error-Messagebox: "Unable to start services." – Marian Lux May 3 '12 at 18:30
45

I ran into the same problem, and I was able to make the same patch work by editing a version number in the script which applies it.

WARNING: I don't actually know what I'm talking about when it comes to VMware patching, I just made an educated guess that seems to work.

Whether you want to try this yourself depends on how risk-averse you are. But hey, your VMware Player install is already broken, right? I figured worst-case scenario I could uninstall and reinstall version 4.0.2.

I based this on the instructions I found here: vmware player compile issue. To boil it down to the simplest steps:

  1. Download this tarball: http://weltall.heliohost.org/wordpress/wp-content/uploads/2012/01/vmware802fixlinux320.tar.gz
  2. Extract the tarball in your home directory
  3. Edit the file patch-modules_3.2.0.sh. Look for the line plreqver=4.0.2 and change it to plreqver=4.0.3
  4. Save the file, then run it. sudo ./patch-modules_3.2.0.sh

If you have run the same patch on version 4.0.2 before, you may get this error: "/usr/lib/vmware/modules/source/.patched found. You have already patched your sources. Exiting". If you see that, just delete the /usr/lib/vmware/modules/source/.patched file and try again.


Please remember to have patch packet installed: apt-get install patch. My default installation of latest Kubuntu didn't have it, so I got error:

./patch-modules_3.2.0.sh: line 42: patch: command not found

Sometimes, the version check does not properly. In this case, you could remove it by deleting the 4 lines following "unset product", all of them begin with "[". This again may increse the risk of breaking something.

  • +1 Awesome, It worked after changing 4.0.2 to 4.0.3 – Caterpillar Jun 3 '12 at 4:37
  • 4
    This workaround also works for Vmware Player 4.0.4 (change 4.0.2 or 4.0.3 in the patch-modules_3.2.0.sh-File to "4.0.4"; check if "patch"-package is installed on your system or get it from the Ubuntu Software Center; remove the ".patched" file if you get an error during patching - if you have already patched for an other version - type: /usr/lib/vmware/modules/source/.patched in terminal) – Marian Lux Jun 15 '12 at 9:53
  • @dbrewer, I got this from a submitted edit but I can't tell if it's correct, can you look at it and see if it's necessary to add to your answer? "Helllo, your answer is very strong and congratulate!!!! But i have to mention that after editing the patch-modules_3.2.0.sh file we need to change not only the plreqver=4.0.3 but also the vmreqver=8.0.4 and follow the steps that you described. AND it'll work." – Jorge Castro Jul 25 '12 at 20:50
  • Hi Jorge. I'm not sure if that's correct either. I know that when I originally did this I only had to do exactly what I described in my original answer, and that I haven't had to change anything since to keep VMware Player working. But, I have to concede that it's possible things have changed since I did this in May, since updated versions of both the kernel and VMware Player have been released since then... – dbrewer Jul 31 '12 at 16:17
  • I have the same problem with VMPlayer 5.0.1 Will this patch work also for this version ? – Pierre de LESPINAY Dec 19 '12 at 7:20
2

Works for different Versions, i tested it with version 4.0.4.744019:

Run vmware-installer -l in a console to get version number.

Edit the file patch-modules_3.2.0.sh:

  1. Look for the line plreqver=4.0.2 and change it to plreqver=[copy and paste version number, just the three digit x.x.x ]

  2. Remove the following lines:

    unset product [ -z "$vmver" ] && error "VMWare is not installed (properly) on this PC" [ "$vmver" == "workstation$vmreqver" ] && product="VMWare WorkStation" [ "$vmver" == "player$plreqver" ] && product="VMWare Player" [ -z "$product" ] && error "Sorry, this script is only for VMWare WorkStation $vmreqver or VMWare Player $plreqver"

    [ "id -u" != "0" ] && error "You must be root to run this script" [ -f "$ptoken" ] && error "$ptoken found. You have already patched your sources" [ ! -d "$basedir" ] && error "Source '$basedir' directory not found, reinstall $product" [ ! -f "$fpatch" ] && error "'$fpatch' not found. Please, copy it to the current '$curdir' directory"

Now run the patch via sudo sh patch-modules_3.2.0.sh

Not the answer you're looking for? Browse other questions tagged or ask your own question.