1

So after accepting a regular update my system rebooted to no network devices. Wifi or ethernet.

Uname indicated a new kernel had been installed. 5.8.0.38

My devices are :

Qualcomm Atheros AR8151 V2.0 Gigabit Ethernet [1969:1083] (rev c0)

Qualcomm Atheros AR93xx Wireless Network Adapter [168c:0030] (rev c1)

After looking at these similar issues:

network not working updating to kernel 5.8 ubuntu 20.04

bcmwl-kernel-source broken on kernel: 5.8.0-34-generic

I installed the 5.8.0.36 modules and headers but still no network!

If a grub boot to the previous kernel everything works!

What should I look at next?

2
  • 1
    Maybe have a look here: bugs.launchpad.net/ubuntu To see if your issue is already reported. – LarsJoo Jan 19 at 5:45
  • i tried sudo modprobe atl1c and sudo modprob3e ath9k but receive fatal error Module xxx not found in /lib/modules/5.8.0-38-generic. Looking in that directory all the files for those devices that are in the 5.4.0-62-generic directory structure are present. So don't know whats wrong. – WallyZ Jan 19 at 5:58
2

I had the same issue and it was solved by also installing linux-modules-extra package (i.e. linux-modules-extra-5.8.0-34-generic)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.