I have a Dell Vostro 15 3000 running (X)Ubuntu 18.04. It's been working well, but yesterday I noticed the Bluetooth icon missing from the taskbar and started investigating why.

The issue seems to be that the Bluetooth device my computer has is gone. This is a normal startup log, or at least what I understand to be normal, from kern.log:

Jan  4 08:24:15 serenity kernel: [   10.593120] Bluetooth: Core ver 2.22
Jan  4 08:24:15 serenity kernel: [   10.593130] NET: Registered protocol family 31
Jan  4 08:24:15 serenity kernel: [   10.593131] Bluetooth: HCI device and connection manager initialized
Jan  4 08:24:15 serenity kernel: [   10.593134] Bluetooth: HCI socket layer initialized
Jan  4 08:24:15 serenity kernel: [   10.593135] Bluetooth: L2CAP socket layer initialized
Jan  4 08:24:15 serenity kernel: [   10.593136] Bluetooth: SCO socket layer initialized

However, yesterday this appeared in the logs upon startup:

Jan 16 09:31:51 serenity kernel: [   19.944964] Bluetooth: hci0: command 0x0c52 tx timeout

After this happened, no more Bluetooth. I tried restarting, I tried an older kernel, I double-checked the Bluetooth is activated in the BIOS, I tried loading manually the necessary kernel modules. I've listed those using a similar laptop I have, and are the following:

bluetooth             544768  14 btrtl,btintel,btbcm,bnep,btusb,rfcomm
ecdh_generic           16384  1 bluetooth

However, it's like the device is not there.

Also, this started showing up in kern.log now:

Jan 16 20:13:34 serenity kernel: [    2.768790] usb 1-10: device descriptor read/64, error -71
Jan 16 20:13:34 serenity kernel: [    3.004853] usb 1-10: device descriptor read/64, error -71

I'm absolutely puzzled. The problem looks very similar to the one posted here, but I've tried resetting the device and it doesn't work. The laptop has been off all night and the device is still missing. If anyone could point me in the right direction I'd be grateful.

More information:

$ lsusb 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0bda:5520 Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 002: ID 045e:07f8 Microsoft Corp. Wired Keyboard 600 (model 1576)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

No Bluetooth device there. Also:

$ rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Thanks a lot in advance

2 Answers 2


As removing the battery was not an option I used GRUB settings

  • Restarted Ubuntu and pressed ESC to load “Advanced options for Ubuntu"
  • Then selected option to enable network
  • Then option to repair broken packages
  • Finally "resume reboot".

Bluetooth service was back. Check https://www.howtogeek.com/196740/how-to-fix-an-ubuntu-system-when-it-wont-boot/#:~:text=Use%20Recovery%20Mode%20If%20You%20Can%20Access%20GRUB&text=Select%20the%20%E2%80%9CAdvanced%20options%20for,the%20submenu%20and%20press%20Enter.

recovery mode

  • Welcome to AskUbuntu and thank you for contributing. Please take the tour. Feb 5 at 6:00
  • 2
    I've realized that my previous answer is a bit ambiguous. When I say "unplugging the battery" I mean just to unplug it from the charger, not remove it entirely from the computer. That solved the issue for me at least. Feb 6 at 16:14

Ok, I managed to solve this issue. It was a purely hardware issue. After finding this discussion in the Dell support forums, I tried turning the laptop off and unplugging it from the power charger. The next time the system went up, the Bluetooth device was there, and that mysterious USB device was gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.