0

I am new to Linux. I have installed kubuntu using a USB boot on my new PC yesterday, and today I installed gnome as well. I was trying to set up my system and did some research. For some reason, I ran the command sudo do-release-upgrade and the command line started printing commands. I waited and got a notification saying that I do not have enough disk space. This is what I see on my disk usage analyser.

Also, after the Low Disk Space on "Filesystem root" notification popped up, my PC freezes and both my mouse and keyboard cannot move. I tried to power off and power on again and nothing is showing after the Kubuntu logo.

Any help is appreciated, thanks in advance.

Update 1

I went to recovery mode and used that terminal there.

Output for systemctl -p 0..3:

Output

Output for systemctl --list-boots:

Output

Update 2

More details from the Disk Usager Analyzer

Also, how do I clean up my disk space, will I need to give up my files? and clear my hard disk?

9
  • Please show journalctl -p 0..3 Maybe something is filling your system logs or logrotate is not working. Also journalctl --list-boots please edit your question for output. – nobody Jan 17 at 10:57
  • @nobody I powered off my PC and tried to power on again but nothing is showing up anymore after the Kubuntu logo. – YYY Jan 17 at 11:14
  • I’d be inclined to start again with the version of Ubuntu you want to run. The do-release-upgrade will upgrade you from one version to another, like 20.04 to 20.10. It can go wrong, perhaps if you didn’t fully update the starting version before doing the upgrade. So if you want Kubuntu 20.10 download the installation media for that version and update your usb. If you have any data on your broken installation that you want to keep just boot the installation usb, choose Try Ubuntu and copy the data to a external device. – PonJar Jan 17 at 12:13
  • @PonJar Thanks, what should I do now with my full disk? It is full now. – YYY Jan 17 at 12:16
  • Your system seems to be filling /var/log, but you likely won't be able to open a multi-GB logfile to read what the problems are. Advice: Wipe-and-reinstall. Promptly begin monitoring your /var/log/syslog; if the problem re-occurs, catch it early so you have time to fix it. – user535733 Jan 17 at 12:24
0

you have some kind of problem with a network device. (there I cannot help)

and persistentes journaling.

In recovery mode.

change in /etc/systemd/journald.conf

Storage=persistent

to

Storage=auto

rotate journal

journalctl --rotate

and

journalctl --vacuum-time=1s

Make a reboot in recovery mode an remove

rm -rf /var/log/journal

Identify oldest /var/log/syslog and kernlog

ls  /var/log/ | egrep 'syslog.*'

and for kern.log

ls  /var/log/ | egrep 'kern.log.*'

Example from me

kern.log
kern.log.1
kern.log.2.gz
kern.log.3.gz
kern.log.4.gz

remove all files with suffix .gz in both cases.

then try to reboot normal.

before you make your release upgrade, try to solve your problem with your network device.

1
  • Thanks for your help, I checked my /etc/systemd/journald.conf and Storage is already auto, and I checked my /var/log/ and only found 4 files with .gz, which are dmesg.[1-4].gz, and the output for those two commands are syslog and kern.log respectively, should I remove these two files? – YYY Jan 17 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.