0

When I run lsusb I can see my scanner

enter code hereBus 001 Device 009: ID 04a9:220e Canon, Inc. CanoScan N1240U/LiDE 30

However, when I open "Document Scanner", it gives me the message "No scanners detected".

I am using Ubuntu 20.04.1 LTS.

What do I need to do to make it detect the scanner?

1

There seems to be a driver conflict for many Canon scanners in Ubuntu 20.04, where ippusbxd tries to claim the device, locking it from use. If you disconnect and plug the scanner back into your machine then run dmesg -w, you'll likely see this message somewhere in the output:

usb 1-11: usbfs: process 5756 (ippusbxd) did not claim interface 0 before use

The most common solution is to unplug the scanner, then remove the ippusbxd driver completely:

sudo apt remove ippusbxd

Once this is done, reconnect the scanner. It should be visible and usable in any document scanning application.

1
  • Thanks for the suggestion. It wasn't exactly what I needed, but running dmesg -w told me that the port I was using (via my keyboard) was not powerful enough. So I switched it to my desktop's port and it worked. – Ginger Jan 17 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.