In Ubuntu Mate 18.04.5 there exist keyboard layouts (in the files in /usr/share/X11/xkb/symbols) that I simply cannot Add in the GUI where I configure my keyboard (mate-keyboard-properties). The layouts are not shown to me.

I'm looking to add svorak_A5 from ./se.

Is there a simple config switch that I can throw to make them visible, or am I forced to manually edit XML to expose them as selectable?

  • Could you please be more specific. What is your current Ubuntu (MATE?) version? Have you tried to open mate-keyboard-properties, then click Add to add new layout? What is the name (or language and variant) of missed keyboard layout? Do you want to get typographic symbols or what? Have you tried to make right click on keyboard layout indicator on MATE Panel, then selecting Show Keyboard Layout to view it?
    – N0rbert
    Jan 17, 2021 at 7:47
  • @N0rbert: The XKB layouts are split into base ones and "extras". Most desktops only show the non-extras by default. In my answer I showed how you can make "extras" available in the GUI on standard Ubuntu. Do you know if MATE has some equivalent feature? Jan 17, 2021 at 13:25
  • @N0rbert Yes: 1) 18.04.5 LTS 32-bit with Mate 1.20.1, 2) Yes, 3) Swedish (se) svorak_A5, 4) Not sure what getting typographic symbols means exactly, 5) No. I'll update the Q to clarify.
    – Andreas
    Jan 17, 2021 at 14:05

3 Answers 3


You have to enable extra keyboard layouts in MATE by executing the following command:

gsettings set org.mate.peripherals-keyboard-xkb.general load-extra-items true

Then launch mate-keyboard-properties and add new layout By country, CountrySweden, VariantsSwedish Swedish (Dvorak A5):


and click Add.

  • Worked instantly :-)
    – Andreas
    Jan 17, 2021 at 16:39

If you had used Ubuntu with GNOME, this command would have fixed it:

gsettings set org.gnome.desktop.input-sources show-all-sources true

I think MATE is different, but maybe there is some equivalent to show-all-sources in MATE's dconf settings. You may want to install dconf-editor and use it to browse around and search.

  • It seems we meet every time I ask about keyboards. Yes, that's probably the switch I had a vague memory of. Thanks, I'll check the editor out in the meantime.
    – Andreas
    Jan 16, 2021 at 21:59
  • @Andreas: I watch the keyboard-layout tag and a few similar tags, that's probably why. ;) Jan 16, 2021 at 23:16
  • I looked around in the editor but couldn't find anything relevant. It works fine in Ubuntu desktop but didn't transfer to Mate.
    – Andreas
    Jan 17, 2021 at 5:28
  • 1
    You were right, it was in there somewhere. I probably looked straight at it at some point...
    – Andreas
    Jan 17, 2021 at 16:50

I believe you also want to edit /usr/share/X11/xkb/rules/evdev.xml and base.xml if you have added any custom keyboard layouts.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .