0

I have a Lenovo ThinkPad e14 gen 2 AMD which came with 250 gb WD NVME ssd. I decided to install Ubuntu 18.04 in dual boot with windows in a separate drive. So, I bought a second ssd (Kingston 250gb NVME) to install Ubuntu 18.04 on.

I did the following steps before installing Ubuntu:

  • Disable Bitlocker
  • Disable fast startup
  • Disable secure boot in BIOS

I then created a live USB using balena etcher and this Ubuntu iso image

From the boot menu I chose the usb and proceeded with the installation normally.

In the disk partition part, I left the first ssd labelled /dev/nvme0n1 (Windows drive) untouched and to the new ssd (/dev/nvme1n1) I made the following partitions.

  • efi - 512 mb Primary - Beginning
  • swap - 16000 mb Primary - Beginning
  • / - 60000 mb Primary - Beginning - /ext4
  • /home - 173547 mb Primary - Beginning - /ext4

For the device for bootloader installation I picked the new drive (/dev/nvme1n1) I proceeded with the installation and rebooted and removed the usb. I intended to install grub in the efi partition. After rebooting I was presented with the grub menu and I realized that the new ssd was partitioned as MBR, because of which I think the bootloader was in MBR and not efi partition. I can boot into both windows and Ubuntu but the times are not syncing. I'm not sure if what I have done is correct.

My question is:

  • Why did Ubuntu install as MBR and not gpt even though my laptop is uefi and windows is uefi?
  • Why didn't Ubuntu install grub in efi partition?
  • Why does the efi partition in ssd 2 show up as local disk D in windows 10?
  • Will Ubuntu in proper efi mode solve the time sync issue?
  • If I need to reinstall Ubuntu how can I do it safely?
  • What change should I make during installation or the bios to install Ubuntu correctly(UEFI with correct bootloader)?

EDIT: On running the command

test -d /sys/firmware/efi && echo efi || echo bios

I get the output:

efi

Does this mean that Ubuntu is booting from efi, then why did the drive get partitioned as mbr?

ssd1 windows partition
ssd2_ubuntu_partitions
partitions
partition_on_windows
thinkpad_boot_menu

1
  • If you used Rufus to create installer, you selected MBR/CSM/BIOS mode. You have to select UEFI/gpt mode. It only creates an installer for BIOS or only UEFI. Other tools create one that can boot in either mode, but you have to select from UEFI boot menu the UEFI:flashdrive option. Where flashdrive is name or label of flashdrive. See also: askubuntu.com/questions/1296065/… Make sure drive is gpt as Ubuntu will let you install to MBR(msdos). Converting from MBR to gpt:ubuntuforums.org/showthread.php?t=1454252 – oldfred Jan 16 at 20:13
2

The MBR/GPT issue, and the UEFI/legacy issues are separate. If you had created a GPT partition table in the device, the installer would have used it. Always install Linux in UEFI if at all possible.

The time difference between Windows and Linux results from Windows using local time in its RTC, which is wrong.

To fix this error in Windows, copy the text between the horizontal lines below and put it in a file named timechange.reg, save it on your Windows partition, then click it while running Windows:


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation] "RealTimeIsUniversal"=dword:00000001


The above will tell Windows to use the same RTC convention as Linux, i.e. UTC, not local time. After this change, you won't see time changes between Windows and Linux any more.

1
  • Thanks for fix regarding the time issue. Is it better to set Windows to UTC time or to set Ubuntu to local time? – concorde42 Jan 17 at 3:04
0

The time sync issue has happened to me before. The cause of this is the way linux and windows use the hardware clock's time. Windows uses local time while linux uses UTC. This can be fixed easily https://www.howtogeek.com/323390/how-to-fix-windows-and-linux-showing-different-times-when-dual-booting/

Why does the efi partition in ssd 2 show up as local disk D in windows 10? This is just the way windows displays your local drives, this is the equivalent of linux's /dev/sd*

Sorry I couldn't help with all of your questions, hope this helps.

1
  • Thanks for the time issue fix. The efi partition showing up in windows explorer is because of it being formatted as FAT32 right? Is there a way to disable it from showing in windows explorer? – concorde42 Jan 17 at 3:03
0

I have found a solution to all my questions.

The three main issues I had were:

  • My second ssd was partitioned as MBR and not GPT

Solution:

The reason this happened is that after I had installed the ssd. I had created a MBR partition and not GPT in Windows Disk Manager. To fix this I deleted all the partitions in the second ssd and opened it again in Windows disk manager and this time partitioned it as GPT.

  • Ubuntu installer was not installing the bootloader to the drive partition I had selected

Solution:

Apparently this is a bug in the Ubuntu installer from a long time . I used the solution given in this answer to workaround the bug.

https://askubuntu.com/a/1056079/1172133

  • The time was different in Windows and Ubuntu

Solution:

I fixed this by setting the time in Ubuntu to use local time instead of UTC as described here https://www.howtogeek.com/323390/how-to-fix-windows-and-linux-showing-different-times-when-dual-booting/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.