1

Update: If in Grub I boot to 5.4.0-60 (recovery mode), I select network, and then I continue rebooting, I get both WiFi and full res. I guess this helps learning how to fix the problem.


OP: It happened to me before (in this and another Ubuntu 20.04 system that I have) that once in a while, after a reboot I have no sound and/or WiFi. As I reported here, that happens after an automatic kernel upgrade and subsequent reboot. For some reason, the required drivers package is not automatically installed alongside.

Today I have turned on my PC, and the only available resolution, at the console, was 640x480. When connecting via xRDP, I got 1366x768, the resolution of my client. I checked

$ uname -r
5.4.0-60-generic

so I installed

$ sudo apt-get install linux-modules-nvidia-390-5.4.0-60-generic

(this might have not been the right move). After a reboot, I have again 1920x1080, but now I have no WiFi.

If rebooting and choosing kernel 5.4.0-58 in Grub, I have WiFi but 640x480, so I cannot get both.

What is causing the problem, and what is the solution?

Why would I have different configurations in kernels .58 and .60?

Some system information below may help. Notes:

  1. I have installed linux-modules-nvidia-390-5.4.0-60 at 2021-01-14 14:00:36.

  2. There is a strange sequence of automatic operations that took place automatically, just before that, for instance:

    2.1. install linux-modules-nvidia-390-5.4.0-56-generic:amd64 5.4.0-56.62

    2.2. remove linux-modules-nvidia-390-5.4.0-56-generic:amd64 5.4.0-56.62

  3. I have also manually attempted sudo apt-get install linux-modules-nvidia-390-5.4.0-58-generic, after 15:00, and I obtained that the package was already the latest version. I don't know if it was installed along the manual installation of 5.4.0-60 (as per log below, it doesn't seem to be the case), or automatically at about 13:47 (although log shows status half-installed linux-modules-nvidia-390-generic-hwe-20.04:amd64 5.4.0-58.64 which I am not sure it is the same).


Possibly related (although I found no specific answer)

  1. How to fix Ubuntu 20.04 upgrade 5.8.0-
  2. Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Some system information

$ apt-mark showmanual | grep ^linux
linux-generic
linux-headers-5.4.0-39-generic
linux-headers-5.4.0-40-generic
linux-modules-5.4.0-42-generic
linux-modules-extra-5.4.0-39-generic
linux-modules-extra-5.4.0-40-generic
linux-modules-extra-5.4.0-42-generic
linux-modules-extra-5.4.0-58-generic
linux-modules-extra-5.4.0-60-generic
linux-modules-nvidia-390-5.4.0-58-generic
linux-modules-nvidia-390-5.4.0-60-generic
linux-modules-nvidia-390-generic-hwe-20.04

$ apt-mark showauto | grep ^linux
linux-base
linux-firmware
linux-headers-5.4.0-39
linux-headers-5.4.0-40
linux-headers-5.4.0-42
linux-headers-5.4.0-42-generic
linux-headers-5.4.0-58
linux-headers-5.4.0-58-generic
linux-headers-5.4.0-60
linux-headers-5.4.0-60-generic
linux-headers-generic
linux-image-5.4.0-39-generic
linux-image-5.4.0-40-generic
linux-image-5.4.0-42-generic
linux-image-5.4.0-58-generic
linux-image-5.4.0-60-generic
linux-image-5.8.0-36-generic
linux-image-generic
linux-libc-dev
linux-modules-5.4.0-39-generic
linux-modules-5.4.0-40-generic
linux-modules-5.4.0-58-generic
linux-modules-5.4.0-60-generic
linux-modules-5.8.0-36-generic
linux-modules-nvidia-390-5.8.0-36-generic
linux-sound-base

$ cat -n /var/log/dpkg.log | grep linux- | grep nvidia
   385  2021-01-14 13:45:11 status installed linux-modules-nvidia-390-5.4.0-56-generic:amd64 5.4.0-56.62
   386  2021-01-14 13:45:11 remove linux-modules-nvidia-390-5.4.0-56-generic:amd64 5.4.0-56.62 <none>
   387  2021-01-14 13:45:11 status half-configured linux-modules-nvidia-390-5.4.0-56-generic:amd64 5.4.0-56.62
   388  2021-01-14 13:45:12 status half-installed linux-modules-nvidia-390-5.4.0-56-generic:amd64 5.4.0-56.62
   389  2021-01-14 13:45:13 status config-files linux-modules-nvidia-390-5.4.0-56-generic:amd64 5.4.0-56.62
   478  2021-01-14 13:47:22 install linux-modules-nvidia-390-5.8.0-36-generic:amd64 <none> 5.8.0-36.40~20.04.1
   479  2021-01-14 13:47:22 status half-installed linux-modules-nvidia-390-5.8.0-36-generic:amd64 5.8.0-36.40~20.04.1
   480  2021-01-14 13:47:23 status unpacked linux-modules-nvidia-390-5.8.0-36-generic:amd64 5.8.0-36.40~20.04.1
   481  2021-01-14 13:47:23 upgrade linux-modules-nvidia-390-generic-hwe-20.04:amd64 5.4.0-58.64 5.8.0-36.40~20.04.1
   482  2021-01-14 13:47:23 status half-configured linux-modules-nvidia-390-generic-hwe-20.04:amd64 5.4.0-58.64
   483  2021-01-14 13:47:23 status unpacked linux-modules-nvidia-390-generic-hwe-20.04:amd64 5.4.0-58.64
   484  2021-01-14 13:47:23 status half-installed linux-modules-nvidia-390-generic-hwe-20.04:amd64 5.4.0-58.64
   485  2021-01-14 13:47:23 status unpacked linux-modules-nvidia-390-generic-hwe-20.04:amd64 5.8.0-36.40~20.04.1
   645  2021-01-14 13:49:27 configure linux-modules-nvidia-390-5.8.0-36-generic:amd64 5.8.0-36.40~20.04.1 <none>
   646  2021-01-14 13:49:27 status unpacked linux-modules-nvidia-390-5.8.0-36-generic:amd64 5.8.0-36.40~20.04.1
   647  2021-01-14 13:49:27 status half-configured linux-modules-nvidia-390-5.8.0-36-generic:amd64 5.8.0-36.40~20.04.1
   648  2021-01-14 13:49:28 status installed linux-modules-nvidia-390-5.8.0-36-generic:amd64 5.8.0-36.40~20.04.1
   653  2021-01-14 13:49:28 configure linux-modules-nvidia-390-generic-hwe-20.04:amd64 5.8.0-36.40~20.04.1 <none>
   654  2021-01-14 13:49:28 status unpacked linux-modules-nvidia-390-generic-hwe-20.04:amd64 5.8.0-36.40~20.04.1
   655  2021-01-14 13:49:28 status half-configured linux-modules-nvidia-390-generic-hwe-20.04:amd64 5.8.0-36.40~20.04.1
   656  2021-01-14 13:49:28 status installed linux-modules-nvidia-390-generic-hwe-20.04:amd64 5.8.0-36.40~20.04.1
   685  2021-01-14 14:00:36 install linux-modules-nvidia-390-5.4.0-60-generic:amd64 <none> 5.4.0-60.67
   686  2021-01-14 14:00:36 status half-installed linux-modules-nvidia-390-5.4.0-60-generic:amd64 5.4.0-60.67
   687  2021-01-14 14:00:37 status unpacked linux-modules-nvidia-390-5.4.0-60-generic:amd64 5.4.0-60.67
   689  2021-01-14 14:00:37 configure linux-modules-nvidia-390-5.4.0-60-generic:amd64 5.4.0-60.67 <none>
   690  2021-01-14 14:00:37 status unpacked linux-modules-nvidia-390-5.4.0-60-generic:amd64 5.4.0-60.67
   691  2021-01-14 14:00:38 status half-configured linux-modules-nvidia-390-5.4.0-60-generic:amd64 5.4.0-60.67
   692  2021-01-14 14:00:41 status installed linux-modules-nvidia-390-5.4.0-60-generic:amd64 5.4.0-60.67
0

Now that kernel 5.8.0-43 is out, an update to that version solved the problem. I guess I will never know what went wrong.

Note that I had to apply this same solution, with a manual installation sudo apt-get install linux-modules-extra-5.8.0-43-generic.

As mentioned here, I also installed linux-generic and linux-generic-hwe-20.04. I will wait until the next update to confirm whether everything gets updated automatically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.