0

I have a package that has already been released.

I have a new version of the package that I'd like to release but I've learned that there is a bug in my original 'prerm' script that will cause some serious problems for users who have already installed the original package.

I can fix this for users going forward so that the upgrade from v2 to v3 and so on goes smoothly; but this doesn't help users with v1.

Is there any magic I can do so that, during the install of my v2 package, some code of mine is executed BEFORE 'prerm' of the old package? From this documentation it seems like the very first thing that happens is the old-prerm script is executed.

Is there anything else I can do here?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.