0

just installing lutris, the the first time i ran it it went straight into a crash message and since then it won't run at all, even after a remove and reinstall. It's present in my apps but clicking it does nothing. I couldn't see any processes for it when i ran top. Tried using the submit issue command and this was the result if that helps. It was also the result of the lutris -d command. I'm a complete noob at linux (don't even know what the -d command does) but what's going on?

lutris --submit-issue
Traceback (most recent call last):
  File "/usr/games/lutris", line 54, in <module>
    from lutris.gui.application import Application  # pylint: disable=no-name-in-module
  File "/usr/lib/python3/dist-packages/lutris/gui/application.py", line 53, in <module>
    from .lutriswindow import LutrisWindow
  File "/usr/lib/python3/dist-packages/lutris/gui/lutriswindow.py", line 26, in <module>
    from lutris.gui.widgets.sidebar import LutrisSidebar
  File "/usr/lib/python3/dist-packages/lutris/gui/widgets/sidebar.py", line 6, in <module>
    from lutris import platforms, runners, services
  File "/usr/lib/python3/dist-packages/lutris/platforms.py", line 19, in <module>
    _init_platforms()
  File "/usr/lib/python3/dist-packages/lutris/platforms.py", line 14, in _init_platforms
    runner = runners.import_runner(runner_name)()
  File "/usr/lib/python3/dist-packages/lutris/runners/wine.py", line 229, in __init__
    "default": dxvk.DXVKManager().version,
  File "/usr/lib/python3/dist-packages/lutris/util/wine/dxvk.py", line 56, in version
    return self.versions[0]
  File "/usr/lib/python3/dist-packages/lutris/util/wine/dxvk.py", line 45, in versions
    self._versions = self.load_dxvk_versions()
  File "/usr/lib/python3/dist-packages/lutris/util/wine/dxvk.py", line 65, in load_dxvk_versions
    with open(versions_path, "r") as dxvk_version_file:
FileNotFoundError: [Errno 2] No such file or directory: '/home/indraneelan/.local/share/lutris/runtime/dxvk/dxvk_versions.json'

i followed these steps linuxconfig.org/… mainly: $ sudo add-apt-repository ppa:lutris-team/lutris then: $ sudo apt update $ sudo apt install lutris If I'm on the administrator account and using sudo can it be a permissions problem?

  • Read the error message "'No such file or directory: '/home/indraneelan/.local/share/lutris/runtime/dxvk/dxvk_versions.json''". You are missing a file or you have a permission problem. How did you install lutris? See https://github.com/waltinator/pathlld to explore permissions. – waltinator Jan 13 at 20:23
  • Comments are designed for US to ask YOU questions about your Question. You should Edit your question to add information. By updating your Question, and using the formatting buttons, you make all the information available to new readers. People shouldn't have to read a long series of comments to get the whole story. – waltinator Jan 14 at 2:02
  • have added the information into the question – Indraneelan Jan 18 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.