3

I am running Ubuntu 20.04.

Does anyone know how I can resolve this?

root@Ubuntu19-04:~# ubuntu-drivers autoinstall
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 linux-modules-nvidia-460-generic-hwe-18.04-edge : Depends: linux-modules-nvidia-460-5.4.0-60-generic (= 5.4.0-60.67~18.04.1) but 5.4.0-60.67 is to be installed
                                                   Depends: nvidia-kernel-common-460 (<= 460.32.03-1) but it is not going to be installed
                                                   Depends: nvidia-kernel-common-460 (>= 460.32.03) but it is not going to be installed
 nvidia-driver-460 : Depends: libnvidia-gl-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Depends: nvidia-kernel-common-460 (<= 460.32.03-1) but it is not going to be installed
                     Depends: nvidia-kernel-common-460 (>= 460.32.03) but it is not going to be installed
                     Depends: nvidia-kernel-source-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-extra-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-decode-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-encode-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Depends: nvidia-utils-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Depends: xserver-xorg-video-nvidia-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-cfg1-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-ifr1-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-fbc1-460 (= 460.32.03-0ubuntu0.20.04.1) but it is not going to be installed
                     Recommends: libnvidia-decode-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommends: libnvidia-encode-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommends: libnvidia-ifr1-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommends: libnvidia-fbc1-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
                     Recommends: libnvidia-gl-460:i386 (= 460.32.03-0ubuntu0.20.04.1)
E: Unable to correct problems, you have held broken packages.

I tried dpkg --configure -a and apt install -f to no avail.

1
  • 2
    apt-cache policy linux-modules-nvidia-460-generic-hwe-18.04-edge and grep -r deb /etc/apt/sources.list /etc/apt/sources.list.d
    – nobody
    Jan 13 at 10:06
2
  1. Try to install the dependencies manually, e.g. sudo apt install linux-modules-nvidia-460-5.4.0-60-generic and so on... after that run sudo apt update && sudo apt dist-upgrade.
  2. If this does not work, uninstall all nvidia drivers and run ubuntu-drivers autoinstall again.
0

I used the answer to this question: Ubuntu 18.04 broken install problem with libnvidia-common-450 package

But I swapped the package name from

libnvidia-common-450-server

To

nvidia-driver-460-server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.