1

I will begin with a description of the steps I took to install ubuntu.

My computer is an HP Spectre x360, from early 2020.

I attempted to install ubuntu on the same hard drive as windows 10. I created a partition in my C: drive.

Installation seemed to be fine but when it prompted me to remove the drive that I installed ubuntu from upon reboot my device went straight to windows.

Upon further investigation: Fast boot was turned off. Secure boot is turned off. Ubuntu is not added to my boot menu in UEFI.

When I check my disk from windows, it appears that the partition I made for ubuntu is unallocated. But when I boot the ubuntu installer from disk and run through the installation process again, the ubuntu installer indicates that ubuntu is installed on my machine in the appropriate partition.

Any solutions to this problem would be greatly appreciated.

Update: I turned off intel optane as suggested and ensured that all the firmware is up to date. Tried to install ubuntu again but was met with the issue: Executing 'grub-install /dev/nvme0n1 failed. This is a fatal error. I rebooted into windows and in windows it said that my partition created for ubuntu was filled but ubuntu still did not appear in my boot menu, and did not appear anywhere in UEFI.

I am extremely confused and if anyone has anymore suggestions or resources it would be awesome.

3
  • Have you updated UEFI? HP Spectre x360 Disable Optane (should use gpt to boot installer in UEFI mode, but MBR may work) askubuntu.com/questions/1204386/… HP X360 Update UEFI F20 (now may even newer) ubuntuforums.org/showthread.php?t=2439220 HP Pavillion X360 13-a220nw ubuntuforums.org/showthread.php?t=2359510 & bbs.archlinux.org/viewtopic.php?pid=1858477#p1858477 – oldfred Jan 13 at 15:18
  • Thanks, I disabled optane and updated all firmware but I ended up with the issue Executing 'grub-install /dev/nvme0n1 failed. This is a fatal error." Not really sure what to do about this. – Matt Jan 13 at 21:06
  • Does nvme0n1 have an ESP? If so then UEFI setting or Windows fast startup may be preventing write into the ESP. If not it is Ubuntu's Ubiquity installer only installing to first drive, which usually but not always is the Windows drive. Lets see details, use ppa version with your live installer (2nd option) or any working install, not Boot-Repair ISO: Please copy & paste the pastebin link to the Boot-info summary report ( do not post report), do not run the auto fix till reviewed. help.ubuntu.com/community/Boot-Repair – oldfred Jan 13 at 23:09
1

Edit: Updated answer for those searching

Try to extend the FAT32 EFI partition to 512MiB , grub has issues with small EFI partitions

If the grub2-efi is not present in UEFI , you may need to reinstall GRUB2(UEFI) , note when you booted ubuntu from usb/live media did you boot via usb [UEFI] , if not you may have installed it via mbr.

You need to launch ubuntu live and reinstall grub2-efi on /EFI partition

  • Go into gnome disks
  • Identify your disk
  • Click the play button on the EFI partition (should be FAT32 and sized ~100mb from windows install)
  • Take note of the EFI mount point (/dev/sda1 something like that)
  • Use command sudo grub-install /dev/sdX , where sdX is your EFI mount point

** Note that if you have an nvme drive it will be something like /dev/nvme0n1p1 instead of sdX , substitute accordingly

  • Use command sudo update-grub

**Important : use blkid command to check UUID of your efi partition, check if it matches the value in your /etc/fstab entry , otherwise ubuntu will not boot , You may need to update the UUID especially if you have formatted EFI partition . (Eg: sudo blkid /dev/sdX)

From :https://linuxsuperuser.com/reinstall-grub2-efi-bootloader-ubuntu/

If it doesnt work , check this https://help.ubuntu.com/community/UEFIBooting#Install_GRUB2_in_.28U.29EFI_systems

4
  • I tried to reinstall ubuntu and ended up with the error message "unable to install grub, grub-install /dev/nvme0n1 fatal, this is a fatal error". I assume that this is a huge issue with installing grub and ubuntu and may be the source of my problems. Running through those tutorials did not work unfortunately and I got path errors. My apologies if I am doing things wrong, I am very new to ubuntu – Matt Jan 13 at 21:18
  • You know what , i may have a theory .The EFI partition is too small , backup EFI contents , make sure that your device is formatted as GPT , make new fat32 EFI partition as 512MiB , then restore contents , try to install grub2 again from previous command line , if that fails try this sudo apt-get install grub2-efi && sudo update-grub . Make sure you have a windows installer & ubuntu live usb before doing this – binaryOps20 Jan 14 at 1:03
  • This was the issue, I extended my EFI partition and disabled optane on the computer and this worked. Disabling Optane was not enough to fix it but extending the EFI partition fixed it. Thank you very much for the help! – Matt Jan 14 at 6:37
  • np , happy to help :) – binaryOps20 Jan 14 at 8:43
0

You can also check in bios setup,

BIOS > System Configuration > Boot device options

And then under UEFI boot order, check OS boot manager

So as to confirm, if ubuntu is installed

3
  • It appears that ubuntu is not located under OS boot manager which is strange considering it appeared that the ubuntu install completed successfully. Thank you for the suggestion @Rishabh – Matt Jan 13 at 8:07
  • You said that, the partition you allocated for ubuntu seems to be unallocated, so did you try extend your C: partition again with that unallocated volume? – Rishabh Pant Jan 13 at 10:30
  • Strangely enough, I am able to extend the windows C: partition again. – Matt Jan 13 at 20:24
0

Theoretically there should be no risk in doing this. That said, TRY THIS AT YOUR OWN RISK:

Enter your system BIOS program and go into your Security Settings. Clear your Security Key Files and turn off Secure Boot. I believe that when Windows 10 is installed particularly if it is an OEM installation, BIOS handles are used and Secure Boot with Security Keys are enabled and generated. This causes subsequently installed boot loader application execution to be ignored (ie., treated as malicious).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.