1

I have tried to update and upgrade my Ubuntu version and after updating, my boot screen is displaying a kernel panic message and I'm unable to access my login screen. I believe that part of the update was the kernel.

screenshot

There is a similar question posted on StackExchange for Ubuntu 16.04, which says to replace the kernel, but I am unsure if this applies to my problem. I don't understand what the output is telling me.

I am using VirtualBox Version 6.1.12 r139181 (Qt5.6.2) for this installation.

4
  • Can you boot into another kernel? Jan 13, 2021 at 3:01
  • No, I've tried others, but they all go into a kernel panic. Jan 13, 2021 at 3:10
  • What did you last do , it look like you failed a kernel recompilation and rebooted Jan 13, 2021 at 3:11
  • I performed an apt get-update and then and apt-get upgrade. During the upgrade there was a Windows blue screen and now this is what happens when I start Ubuntu within the VirtualBox. Jan 13, 2021 at 3:13

1 Answer 1

0

Reboot your VM, then hit Esc or Shift button to get into grub, select another kernel.

If not try selecting recovery option in kernel.

Edit , if you cannot boot then you need to use a live linux boot , then chroot into the hosed system a

14
  • I used "Advanced Options for Ubuntu" to try out different options under Grub, but all have the kernel problem. That includes trying all in recovery mode. So I load a Linux from install disk, and correct from in there? I need to chroot and then... install a new kernel? I'm using Oracle VM VirtualBox Manager in Windows. So I start the live Ubuntu within the VirtualBox, and I can access it like that? Jan 13, 2021 at 3:19
  • That is correct , you can select the ubuntu.iso from the options menu in virtual box , under cd/dvd and set boot order for the cd/dvd to be higher there too Jan 13, 2021 at 3:22
  • 1
    Thanks. I have done that, I loaded from a live CD, used chroot to try to do a new update/upgrade - I used the instructions for "update failure" in help.ubuntu.com/community/LiveCdRecovery However, I now get the error "apt-get: error while loading shared libraries: /lib/x86_64-linux-gnu/librt.so.1: invalid ELF header" Jan 14, 2021 at 1:05
  • Glad you could fix it , good on ya :) Jan 14, 2021 at 1:07
  • Not quite fixed - but making progress - do you have any advice to fix this error that I have now, please? I have recovered my files though, which is great, but would be nice to get the original setup working again. Jan 14, 2021 at 1:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.