1

Running lubuntu 18.04.5, for 32-bit machine. and trying to backup an android phone.

After I installed adb (via LXTerminal), and connected the android phone, I ran 'adb devices' in LXTerminal. Then, the returned 'List of devices attached' is empty.

Is using adb the best way for me to try backing up the phone in lubuntu?

I am a relative newbie to Linux/lubuntu, and I need explicit instructions for using Terminal.

2

You may need to connect via Wifi.

Put in this command:

adb connect 123.456.7.8

123.456.7.8 is replaced with your phone IP address.

6
  • Thank you, Amint. Before I try that, I wanted to add and let you know that the android phone does show up in PCManFM. Do you still think WiFi may help? – Hotspur Jan 12 at 22:51
  • After Terminal command 'adb connect 123.456.7.8', the return message is 'unable to connect to 123.456.7.8:5555: Connection refused' – Hotspur Jan 12 at 23:41
  • Of course, I change 123.456.7.8. to the IP address for the phone. – Hotspur Jan 13 at 1:18
  • I did try connecting via WiFI. Connection was refused. – Hotspur Jan 13 at 3:43
  • 1
    Have you rechecked Developer Settings? USB debugging or ADB debugging may be off. – Amint Jan 13 at 10:21
0

Before I describe the solution that I found, I should first add that in the very beginning, after connecting the phone to the computer via a USB cable, I had to swipe down from the top of the phone's screen, and then change 'Use USB to charge this device' to 'Use USB to Transfer files'. Now back to the solution that I found. I found out from reading https://linuxtechlab.com/install-adb-fastboot-ubuntu/ that first I had to turn on 'USB Debugging' in the 'Developer Options' in Settings in the phone. In order to do that, first I had to 'become' a developer (as far as the phone is concerned, so to speak). In my (UMX U683CL) android phone running Android version 8.1.0, I did that by going to Settings/System/About Phone, and then tapping on 'Software version' six times. The phone then announced that I had become a developer. After that, in order to turn on 'USB debugging', I went to Settings/System/Developer Options, and then toggled on the 'USB debugging' 'switch'. Then, after I commanded 'adb devices' in Terminal, my phone showed up in the returned-list as a connected device.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.