0

I installed Ubuntu 18.04 off a DVD last night.

I added a few basics like gcc, make, build-essential, manpages-dev, dkms, git, a wifi driver (using dkms), curl, gnupg, brave-browser, and Steam. Then today tried to upgrade the OS to version 20.04 via the Software Updater GUI. It got as far as "Installing the Upgrades"

"Focal" window says: Unpacking libselinux1 (amd64)

and in the terminal below:

Preparing to unpack .../libpam0g_1.3.1-5ubuntu4.1_amd64.deb ...
Unpacking libpam0g:amd64 (1.3.1-5ubuntu4.1) over (1.1.8-3.6ubuntu2.18.04.2) ...
Setting up libpam0g:amd64 (1.3.1-5ubuntu4.1) ...
Fontconfig warning: "/etc/fonts/conf.avail/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
Checking for services that may need to be restarted...Checking init scripts...```

var/log/dist-upgrade/main.log: 

```2021-01-12 14:37:10,612 DEBUG demoted: 'libdbusmenu-gtk4 libegl1-mesa libllvm6.0'
2021-01-12 14:37:10,612 DEBUG found components: {'focal': {'main', 'universe', 'restricted', 'multiverse'}, 'focal-updates': {'main', 'universe', 'restricted', 'multiverse'}, 'focal-security': {'main', 'universe', 'restricted', 'multiverse'}}
2021-01-12 14:37:10,616 DEBUG quirks: running StartUpgrade
2021-01-12 14:37:10,616 DEBUG running Quirks.StartUpgrade
2021-01-12 14:37:10,616 DEBUG skipping 'README' (no '.')
2021-01-12 14:37:10,616 DEBUG killing update-notifier
2021-01-12 14:37:10,633 DEBUG killing kblueplugd kbluetooth4
2021-01-12 14:37:10,651 DEBUG killing gnome-screensaver
2021-01-12 14:37:10,671 DEBUG setup poke timer for the screensaver
2021-01-12 14:37:10,684 INFO cache.commit()
2021-01-12 14:44:09,474 WARNING no activity on terminal for 300 seconds (Unpacking libselinux1 (amd64))

There's this window off the to side named "Frontend" that says "Configuring libpamOg:amd64" and has a checkbox that says "Restart services during package upgrades without asking?" Toggling it does nothing.

I can't open the "Files" app nor the System Settings app.

What should I do now?

5
  • Ubuntu 18? Ubuntu desktop and server releases have a yy.mm format, and whilst specialist snap based releases like Ubuntu Core 18 for IoT appliances do use a yy format there are none titled just Ubuntu 18. Please clarify your releases are your usage of yy based releases implies snap only Ubuntu releases, but your tag & description don't match that. – guiverc Jan 12 at 21:52
  • Installing an older release only to attempt to immediately upgrade to a new release is not a good plan. I suggest that you just install 20.04 cleanly. See: Create a bootable USB stick on Ubuntu / Windows | Install Ubuntu desktop – Nmath Jan 12 at 22:22
  • Sorry, that was lazy of me. It was 18.04 to 20.04. – Nextnonce Jan 12 at 23:35
  • Please correct your question (you can edit your own questions), then I can remove my comment. Ubuntu has both yy.mm products, and since 2016 yy products (they are different systems, yy releases have 10 years of support without need of ESM, use snaps only etc). Mixing two different products because of laziness can lead to wrong details (it's better if we're not forced to make assumptions as to what you mean). – guiverc Jan 12 at 23:39
  • I tried "dpkg --configure -a" and it complained about something being locked. So I tried killing the update window with ctrl+C and it wouldn't die. I tried restarting from the OS menu and it hung on restart. So I finally did a hardware reset. And now it won't boot. It says on loading, "Oh no! Something has gone wrong. A problem has occured and the system can't recover. Please log out and try again." So I guess I'll start over with a 20.04 install. If I got stuck on an upgrade after 1 day of use, what chance does anyone else have? – Nextnonce Jan 12 at 23:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.