Recently I've bought Lenovo ThinkPad X1 Carbon Gen8. Everything seems fine except one thing - I can't fully configure fingerprint reader.

I've followed guide https://askubuntu.com/a/1082465/249099 and added

auth    [success=2 default=ignore]  pam_fprintd.so max_tries=3 timeout=10

to /etc/pam.d/common-auth and added my fingerprint using fprintd-enroll $USER.

Console login and KDE lock screen login works fine. Latter not very usable, I need to press enter before system will scan my finger, but at least it work.

Big problem is that SDDM not allows me to login at all. If I press enter as on lock screen - it blocks forever. If I input password - it blocks forever.

I tried to follow https://wiki.archlinux.org/index.php/SDDM#Using_a_fingerprint_reader and added

auth sufficient pam_fprintd.so

to the beginning of /etc/pam.d/sddm but id didn't help, SDDM grays and does not allow me to do anything, I ought to go to virtual console, revert all fingerprint-related settings and restart SDDM from there.

GDM works fine with fingerprint from the box, without any settings from my side.

Could anybody help me setup SDDM to support fingerprint login?

1 Answer 1


I think you need to add this, but don't remove the pam_fprintd.so one:

auth            sufficient      pam_unix.so try_first_pass likeauth nullok
  • Thanks for answer, but where should I add it - to /etc/pam.d/common-auth or /etc/pam.d/sddm? Commented Feb 6, 2021 at 5:56
  • Add it to /etc/pam.d/sddm.
    – Amint
    Commented Feb 6, 2021 at 6:28
  • Changed config, restarted SDDM using systemctl and on appeared login screen see no welcome message about fingerprint but only password input field. If I try to input password and press Enter - SDDM became gray and stuck at it. Commented Feb 6, 2021 at 14:40
  • 3
    Wow. Seems I've found how to deal with it. SDDM shows password input field, I hit Enter, SDDM became gray, I touch fingerprint scanner - and I got into the system! They definitely should make UI better :) auth sufficient pam_fprintd.so addition at the top /etc/pam.d/sddm is enough. Commented Feb 8, 2021 at 17:11
  • 1
    Thank you for the bounty, I really appreciate it. And one more time, congratulations for finding the solution! I'm glad you could find out how it works!
    – Amint
    Commented Feb 8, 2021 at 17:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .