1

Summary: I'd like to set the resolution of my Ubuntu box to 2560x1440 (the resolution of my screen) but the highest that it will go is 1920x1440.

Currently, I tried following this set of instructions: How do I set a custom resolution?

I ran

test@ubuntu20box:~$ cvt 2560 1440 60
# 2560x1440 59.96 Hz (CVT 3.69M9) hsync: 89.52 kHz; pclk: 312.25 MHz
Modeline "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
test@ubuntu20box:~$ xrandr --newmode "2560x1440_60"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
test@ubuntu20box:~$ xrandr 
Screen 0: minimum 1 x 1, current 1920 x 1440, maximum 8192 x 8192
Virtual1 connected primary 1920x1440+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   800x600       60.00 +  60.32  
   2560x1600     59.99  
   1920x1440     60.00* 
   1856x1392     60.00  
   1792x1344     60.00  
   1920x1200     59.88  
   1600x1200     60.00  
   1680x1050     59.95  
   1400x1050     59.98  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1360x768      60.02  
   1280x800      59.81  
   1152x864      75.00  
   1280x768      59.87  
   1024x768      60.00  
   640x480       59.94  
Virtual2 disconnected (normal left inverted right x axis y axis)
Virtual3 disconnected (normal left inverted right x axis y axis)
Virtual4 disconnected (normal left inverted right x axis y axis)
Virtual5 disconnected (normal left inverted right x axis y axis)
Virtual6 disconnected (normal left inverted right x axis y axis)
Virtual7 disconnected (normal left inverted right x axis y axis)
Virtual8 disconnected (normal left inverted right x axis y axis)
  2560x1440_60 (0x163) 312.250MHz -HSync +VSync
        h: width  2560 start 2752 end 3024 total 3488 skew    0 clock  89.52KHz
        v: height 1440 start 1443 end 1448 total 1493           clock  59.96Hz
test@ubuntu20box:~$ xrandr --addmode Virtual1 2560x1440_60
test@ubuntu20box:~$ xrandr -s 16:9
test@ubuntu20box:~$ xrandr -s 2560x1440_60 (RESULTS IN BLANK SCREEN WITH ONLY MOUSE)

The last line above ( xrandr -s 2560x1440_60 ) resulted in a blank screen that I had to use xrandr -s 0 to reset back to an 800x800 display to see anything.

Neither of these two options (2560x1600 and 2560x1440) in display settings works. image of the display settings with resolution options listed

Some more background: I ran and installed the VirtualBox Guest Additions and it is at version 6.1.17 and appears to be installed correctly since I can get a resolution that is higher than 800x800. I have tried the other display adapters in the machine settings.

I have a Ubuntu 16 box that works fine any any resolution. It auto resize the resolution to the window size and everything. I have no idea how to get the Ubuntu 20 ox to do that.

1 Answer 1

1

AHHHHHHHHHHHHHHHHHH

So this problem has been haunting me for the last two freaking days and I just figured it out.

It turns out that I simply needed to allocate more video memory to the machine for a higher resolution. Thats it.

Image of VM Settings

I'll leave this up in case someone else is also struggling later on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.