I have a small office network consisting of a few PCs and one Ubuntu server that we use for file sharing as well as a minidlna server for our music. Everything was working just fine until I upgraded to Ubuntu 18.04. Now none of the Windows machines can see the Ubuntu server on the network. I've exhausted all the so-called "fixes" that I can find and nothing seems to work. I've spent a week and many many hours searching for and implementing different "fixes" all to no avail.

I've performed all the steps outlined here (https://devanswers.co/discover-ubuntu-machines-samba-shares-windows-10-network/) and still not seeing the server. The DLNA service works fine still, but we cannot see the drives we use to store files.

There are no other symptoms. The server works fine otherwise. This is driving me nuts! Please help!

Here are the entries in the config file:

#======================= Global Settings =======================

        panic action = /usr/share/samba/panic-action %d  
        max log size = 1000  
        dns proxy = no  
        directory mode = 775  
        passdb backend = tdbsam  
        force create mode = 775  
        log file = /var/log/samba/log.%m  
        force user = root  
        passwd program = /usr/bin/passwd %u  
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .  
        syslog = 0  
        security = user  
        pam password change = yes  
        server string = %h server (Samba, Ubuntu)  
        path = /home  
        unix password sync = yes  
        usershare allow guests = yes  
        obey pam restrictions = yes  
        os level = 20  
        force directory mode = 775  
        workgroup = WORKGROUP  
        create mode = 775  
        auto services = rbtco_internal  
        server role = standalone server  
        default = global  
        map to guest = bad user  
        force group = root  

        write list = rbtco,rbtco_admin,dave,@rbtco_admin,@rbtco  
        directory mode = 775  
        path = /home/rbtco  
        public = yes  
        valid users = rbtco,rbtco_admin,@rbtco,@rbtco_admin,dave,@dave  
        revalidate = yes  
        writeable = yes  
        create mode = 775  

        write list = rbtco,rbtco_admin,dave,@rbtco_admin,@rbtco,@dave  
        browsable = yes  
        public = yes  
        path = /home/dave  
        directory mode = 775  
        comment = Samba on Ubuntu  
        writeable = yes  
        create mode = 775  

There are a lot more entries but it's difficult formatting them here.

  • 1
    Consider editing your question to include the non-default contents of smb.conf from the server. Copy and paste the text, don't add it as a picture. – Organic Marble Jan 12 at 16:33
  • Please take a look at /var/log/samba/smb.log and post any error messages. Also, can you ping the Ubuntu machine from the windows boxes? Are there any firewall rules set on Ubuntu or any routers that you have on your network? – Barton Chittenden Jan 12 at 18:37
  • 1
    You should enable SMB3 in the config file protocol = SMB3 – Robert Jan 12 at 19:26
  • I added some of the config file entries. the log file is too long to post here but it has things like this in it: 2021/01/12 11:06:26.012309, 0] ../source3/param/loadparm.c:3354(process_usershare_file) process_usershare_file: stat of /var/lib/samba/usershares/rbtco_disk_2 failed. No such file or directory – Gitpicker Jan 12 at 23:23
  • I changed my conf file to this and added the client max protocol = NT1 entry. I can now see the server but not the shared drives. force user = dave client max protocol = NT1 server role = standalone server max log size = 10000 public = yes socket options = TCP_NODELAY path = /home/dave server string = samba_server log file = /var/log/samba/smb.log smb ports = 445 writeable = yes #disable netbios = yes #bind interfaces only = yes – Gitpicker Jan 13 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.