I upgraded my Ubuntu OS on my laptop from 11.10 to 12.04, I did the Virtual Box work arounds mentioned in the thread: VirtualBox doesn't load after 12.04 upgrade, My Turnkey Linux VM's are back up and running now however my windows 7 VM has failed to come up. My whole laptop freezes and i have to force restart my laptop each time I try to start my windows 7 VM.

Is there a work around to ensure smooth startup and running of win 7 VM's

My virtual box version is 4.1.12_Ubuntu r77245


The probably-related VirtualBox bug ticket says it is fixed in VirtualBox source, and also details a workaround via grub.


Hopefully the patch will be applied to Ubuntu-12.04 .


What are your Ubuntu and Windows versions (including 32 bit or 64 bit)?

I also had some problems when setting up VirtualBox 64 bit Windows machine on 32 bit Ubuntu, but everything works fine with 32 bit Windows.

  • The Windows I have is 64bit and the host ubuntu is 32. The same setup was there in 11.10 and things worked just fine. After I upgraded to 12.04 this issue is occurring.
    – darkliquid
    May 4 '12 at 8:32

I had the same problem; 64bit version of Windows 7 machine on 32 bit Ubuntu 12.04. failing to startup with Virtualbox 4.1.14

This setup worked perfectly until I upgraded from Ubuntu 11.10 to 12.04

Removing and reinstall Virtualbox did not solve the problem:

    sudo apt-get remove Virtualbox-4.1
    sudo apt-get install Virtualbox-4.1

ALSO executing:

    sudo aptitude update
    sudo aptitude install dkms
    sudo /etc/init.d/vboxdrv setup

At last I created a 32bit version of Windows 7 machine and it works with fine without any problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.