2

I need to run sudo airmon-ng start wlan0. In 11.10, this works fine, but in 12.04 it doesn't: it cannot find the command. So I ran sudo apt-get install airmon-ng, but this is the result I get:

Building dependency tree
Reading state information... Done
Package aircrack-ng is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
iw
E: Package 'aircrack-ng' has no installation candidate

Any ideas?

4

How to install aircrack-ng on Ubuntu 12.04. Open terminal:

  1. sudo apt-get install build-essential
  2. sudo apt-get install libssl-dev
  3. wget http://download.aircrack-ng.org/aircrack-ng-1.1.tar.gz

Now you can make new directory

  1. mkdir aircrack
  2. cd Downloads
  3. mv aircrack-ng-1.1.tar.gz ~/aircrack
  4. cd ..
  5. cd aircrack
  6. tar -zxvf aircrack-ng-1.1.tar.gz
  7. cd aircrack-ng-1.1
  8. sudo gedit common.mak

in this file find

  1. CFLAGS ?= -g -W -Wall -Werror -O3

delete -Werror to look like this

  1. CFLAGS ?= -g -W -Wall -O3

save and close

  1. make
  2. sudo make install

Here is my tube link: http://www.youtube.com/watch?v=apoaHf8tPVk

1

Another way around it is to grab the latest iw tarball from https://www.kernel.org/pub/software/network/iw/

Remove iw

sudo apt-get remove iw

Then extract the source code from the tarball, compile and install.

0

http://www.aircrack-ng.org/

Built it yourself- I do not know why it is not in 12.04 anymore, but according to aptitude, it has been replaced by or conflicts with the iw package.

% aptitude show iw
Package: iw                              
New: yes
State: installed
Automatically installed: yes
Version: 3.2-1
Priority: optional
Section: net
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Uncompressed Size: 152 k
Depends: libc6 (>= 2.7), libnl-3-200 (>= 3.2.3), libnl-genl-3-200 (>= 3.2.3)
Recommends: crda
Conflicts: iw
Breaks: aircrack-ng (< 1:1.0~rc2-1), aircrack-ng (< 1:1.0~rc2-1)
Replaces: aircrack-ng (< 1:1.0~rc2-1), aircrack-ng (< 1:1.0~rc2-1)
Description: tool for configuring Linux wireless devices
 This package contains the `iw' tool which allows you to configure and show
 information about wireless networking.
0

You can download the required package from teh following link and install it using Ubuntu Software Center-
http://ubuntu2.cica.es/ubuntu/ubuntu/pool/universe/a/aircrack-ng/
You can download either of the following packages depending on your Ubuntu installation(32bit/64bit):
- http://ubuntu2.cica.es/ubuntu/ubuntu/pool/universe/a/aircrack-ng/aircrack-ng_1.1-1_i386.deb
-http://ubuntu2.cica.es/ubuntu/ubuntu/pool/universe/a/aircrack-ng/aircrack-ng_1.1-1_amd64.deb

Courtesy: http://www.aircrack-ng.org/doku.php?id=downloads

N.B: I had installed it successfully on Ubuntu 12.04 using the above package.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.