16

I wanted to backup /var/cache/apt/archives using 'Deja Dup' but it keeps saying >>

Could not backup the following files. Please make sure you are able to open them.

/var/cache/apt/archives/lock

Any help?

  • Were you running any other applications that require root privileges simultaneously? Like Synaptic or something from the command line maybe? – harisibrahimkv May 3 '12 at 9:59
  • Nope. I've even restarted for confirmation. – Mohd Arafat Hossain May 3 '12 at 10:10
  • You ran Deja Dup with sudo? – harisibrahimkv May 3 '12 at 10:11
  • No. Thats my question, I don't know how to open Deja Dup with sudo OR as root xD Sorry for being a noob ;) – Mohd Arafat Hossain May 3 '12 at 10:18
  • 1
    I tried 'sudo deja-dup --backup' by seeing 'sudo deja-dup -h' but it keeps opening 'Ubuntu One', I wanted to use Deja Dup for my backup :( For your recommendation 'sudo deja-dup <path>' how do I find out what the path is? – Mohd Arafat Hossain May 3 '12 at 10:30
23
  1. Configure Deja Dup for your root backup: gksu deja-dup-preferences.

  2. Run backup then with: gksu "deja-dup --backup".

At least this worked for me. (You have to configure Deja Dup for root, too, at first - next to your configuration for the "normal" user.)

As mythsmith says: "You can do that just for system folders, and still keep your home folder configured in your user account."

  • 1
    Did any one tell you how awsome you are ;) Thanks for the help IT WORKED!!!! – Mohd Arafat Hossain May 3 '12 at 12:06
5

In 12.04 the following simple command works, if you have sudo privileges:

sudo deja-dup-preferences
3

Start by:

  1. Run DEJA backup GUI and configure what you want to backup and where to save your backup files, without clicking backup now, just save your backup setting and exit Deja GUI.
  2. Start terminal ALT+CTRL+T and type this command when you are ready to start backup sudo deja-dup --backup.

GUI window will open and backup should start.

  • It does start, but now it can't find my usb plugged in backup drive. – Elliptical view Jul 22 '16 at 21:45
2

If you are interested in having it in the Unity launcher that way, there's a pretty easy way to do so, at least in Ubuntu 16.04.

First, open Nautilus as root:

gksu nautilus /usr/share/applications

You are likely to find three Backup app launchers there:

enter image description here

Locate the one which command is plainly deja-dup-preferences:

enter image description here

Now, with that one selected, use Ctrl+C and Ctrl+V to duplicate it.

enter image description here

Right click on the icon that's highlighted and open Properties. They should be the same that you have seen before. Change them so they look like these:

enter image description here

Once you've made the changes, close that window and drag that icon you just have edited into the Unity Launcher so it's locked there.

enter image description here

That's it. Now every time you click on that launcher, it will request your root password and run deja dup as root instead of your current user.

0

I think you have a few configurations to do with deja-dup first and then run it. Please do try referring to this : http://techie-buzz.com/foss/deja-dup-ubuntu-1.html

  • 2
    I've seen this page before posting the question here.....it only says how to backup regular files (like home, images, videos etc etc) but when you apply the same method in this case (backing up files from File System) which requires user privileges then I get this error. – Mohd Arafat Hossain May 3 '12 at 10:43
  • The page you refer to is now very old: 2011 – Elliptical view Jul 22 '16 at 21:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.