4

I have Ubuntu 20.04.1 LTS Desktop installed in my Lenovo Ideapad 320 Laptop and i had updated system few days back after restarting once finish the installed updates it booted ( kernel 5.8.0-34 generic) but with sluggish graphics and no network. So i tried few things but without network i couldn't do much so i restarted system and from grub advance options i choose older kernel ( 5.4.0-60 generic) and it worked without any issues. see image i have to choose 5.4 from this image to make ubuntu work without issues.ubuntu grub

I then tried again apt-get update and apt-get upgrade commands but no luck it does install all the packages but if i boot with 5.8 kernel it just doesn't boot with network. see attached image for ip addr command (no network interfaces at all) when i boot with 5.8 kernel ip addr output

Can anyone tell me what could be issue here. how do i fix this mess? as whenever i restart i have to press escape and load grub and from advance option choose 5.4 kernel.

Here is the current drivers info from additional drivers tab screen in ubuntu.

  1. Realtek Semiconductor Corp : using dkms source for the r8812au network driver from r8812au-dkms(open source)

  2. NVIDIA Corporation : GM108M [GeForce 940MX] - Using NVIDIA driver metapackage from nvidia-driver-450(proprietary)

Here is output of lshw -c video

  *-display                 
       description: VGA compatible controller
       product: HD Graphics 620
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:128 memory:a2000000-a2ffffff memory:b0000000-bfffffff ioport:6000(size=64) memory:c0000-dffff
  *-display UNCLAIMED
       description: 3D controller
       product: GM108M [GeForce 940MX]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:a3000000-a3ffffff memory:90000000-9fffffff memory:a0000000-a1ffffff ioport:5000(size=128)

dpkg -l output : https://pastebin.com/raw/QNktzj1g

6
  • The issue is that maintainers upgraded kernel and didn't upgrade everything else. You can revert to the 5.4 kernel. And stick with 5.4.0-xx kernels for a while. They will get updates.
    – Pilot6
    Commented Jan 9, 2021 at 20:35
  • hey @Pilot6 how do i that via commands ?
    – hardik
    Commented Jan 9, 2021 at 20:41
  • same problems here, with the wireless card, solved it with askubuntu.com/questions/1005058/… Commented Jan 9, 2021 at 20:43
  • @GiorgosSaridakis both wireless and wired port also doesn't work. it doesn't even shown in ip addr command as well.
    – hardik
    Commented Jan 9, 2021 at 20:45
  • 1
    Hold on, I am writing the commands.
    – Pilot6
    Commented Jan 9, 2021 at 20:47

1 Answer 1

4

You can remove the 5.8 kernel and stick with the 5.4.0-xx kernels this way.

Boot with a 5.4 kernel using grub menu, then run in a terminal:

sudo apt remove linux-image-5.8.0-36-generic linux-modules-5.8.0-36-generic linux-modules-extra-5.8.0-36-generic linux-headers-5.8.0-36-generic linux-hwe-5.8-headers-5.8.0-36
sudo apt install linux-generic
10
  • I did this. it did uninstall but grub still boots on 5.8 and now its completely black. nothing happens. i then restarted the into 5.4 via grub and tried this command again but ubuntu says, "Package 'linux-headers-5.8.0-36-generic' is not installed, so not removed Package 'linux-hwe-5.8-headers-5.8.0-36' is not installed, so not removed Package 'linux-image-5.8.0-36-generic' is not installed, so not removed Package 'linux-modules-extra-5.8.0-36-generic' is not installed, so not removed"
    – hardik
    Commented Jan 9, 2021 at 21:03
  • Some is wrong. The command should remove 5.8 completely. Please add output of dpkg -l | grep linux to your question. I'll see what was wrong. And I edited the command, added one package after the initial post.
    – Pilot6
    Commented Jan 9, 2021 at 21:04
  • added dpkg -l output as pastebin to question.
    – hardik
    Commented Jan 9, 2021 at 21:12
  • 1
    that was because of my initial mistake. Now run sudo apt remove linux-modules-5.8.0-36-generic and all will be fixed.
    – Pilot6
    Commented Jan 9, 2021 at 21:16
  • Yep It did work i had to run two commands though, sudo apt remove linux-modules-5.8.0-36-generic and sudo apt remove --purge linux-image-unsigned-5.8.0-36-generic and then sudo update-grub
    – hardik
    Commented Jan 9, 2021 at 21:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .