I added some extra repositories with the Software Sources program. But when I reload the package database, I get an error like the following:

W: GPG error: http://ppa.launchpad.net trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8BAF9A6F

I know I can fix it using apt-key in a terminal, according to the official Ubuntu documentation. But I would have liked to do it graphically. Is there a way to do this without using a terminal?

  • Related: askubuntu.com/q/127326/178596 – Wilf Jul 19 '15 at 20:46
  • 'A mean'? Curious what you meant by that. – Michael Scheper Sep 13 '16 at 16:17
  • 1
    You can check this SO thread for solution. Link to related site – Aniket Thakur Oct 6 '16 at 3:44
  • @MichaelScheper 'Is there a mean[s] to not to open a terminal?' =~ 'Is there a way to do it without a terminal?' – Wilf Jul 26 '17 at 0:26
  • @Wilf: Oh! I don't mean to nitpick grammar, but it did confuse me. From the reference I just checked, 'means' is a singular noun, and the one you meant. dictionary.cambridge.org/dictionary/english/means But if you and Agmentor are using some variant form of English where the grammar in the question is correct, I'd love to see a reference to it, just because I'm interested in that sort of thing. ☺ – Michael Scheper Jul 26 '17 at 17:35

12 Answers 12


By far the simplest way to handle this now is with Y-PPA-Manager (which now integrates the launchpad-getkeys script with a graphical interface).

  1. To install it, first add the webupd8 repository for this program:

    sudo add-apt-repository ppa:webupd8team/y-ppa-manager
  2. Update your software list and install Y-PPA-Manager:

    sudo apt-get update
    sudo apt-get install y-ppa-manager
  3. Run y-ppa-manager (i.e. type y-ppa-manager then press enter key).

  4. When the main y-ppa-manager window appears, click on "Advanced."

  5. From the list of advanced tasks, select "Try to import all missing GPG keys" and click OK.

    You're done! As the warning dialog says when you start the operation, it may take quite a while (about 2 minutes for me) depending on how many PPA's you have and the speed of your connection.

| improve this answer | |
  • 29
    Not really useful in a webserver, as this installs X11. Don't use this method if you're on a server edition, check karthick87's answer! – goncalotomas Feb 11 '16 at 20:13
  • 2
    Does this allow to verify the keys which are imported, or are you simply blindly importing everything (and therefore trusting everyone who has a PPA)? – Paŭlo Ebermann Sep 6 '16 at 10:36
  • 2
    You're importing (and trusting) the keys for every PPA you've added to your system. The assumption is that you trust those PPA's and have checked them out before you added them via apt. – monotasker Sep 6 '16 at 14:25
  • 6
    This answer is easier by far, and actually requires fewer commands than this "graphical" answer. – jpaugh Jul 27 '17 at 19:37
  • 1
    But the question asked for a graphical method. – monotasker Jul 28 '17 at 22:30

Execute the following commands in terminal

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys <PUBKEY>

where <PUBKEY> is your missing public key for repository, e.g. 8BAF9A6F.

Then update

sudo apt-get update


sudo gpg --keyserver pgpkeys.mit.edu --recv-key  <PUBKEY>
sudo gpg -a --export <PUBKEY> | sudo apt-key add -
sudo apt-get update

Note that when you import a key like this using apt-key you are telling the system that you trust the key you're importing to sign software your system will be using. Do not do this unless you're sure the key is really the key of the package distributor.

| improve this answer | |
  • 2
    @Naruto That's normal. It means that list hasn't changed on the server. – nanofarad Aug 10 '12 at 15:50
  • 12
    You can simply pass NO_PUBKEY value as keys parameter. for example GPG error[...]NO_PUBKEY 3766223989993A70 => sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 3766223989993A70 – S.M.Mousavi Feb 19 '14 at 19:40
  • 27
    8BAF9A6F <-- where did you get that number? – Olivier Lalonde Mar 9 '14 at 12:49
  • 14
    The number 8BAF9... is what you see in the original error. It would be something like NO_PUBKEY 8BAF... – Alex Oct 10 '14 at 19:56
  • 10
    If someone tampered with data between me and the repository, and substituted stuff they'd signed, this would wind up with me just adding the key they used, more or less blindly. So what's the process to verify that the key is the right one? – mc0e May 20 '15 at 15:37

It happens when you don't have a suitable public key for a repository.

To solve this problem use this command:

gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv 9BDB3D89CE49EC21

which retrieves the key from ubuntu key server. And then this:

gpg --export --armor 9BDB3D89CE49EC21 | sudo apt-key add -

which adds the key to apt trusted keys.

The solution can be found here & here & here.

| improve this answer | |
  • 4
    If the hkp://keyserver.ubuntu.com is not working use this pgpkeys.mit.edu server. – RajaRaviVarma Oct 30 '13 at 10:06
  • 2
    This answer solved my issue with Kylin repository. The sogou pinyin input method added source to my /etc/apt/sources.list.d/ folder, but apparently didn't import gpg key. Good answer , simple and to the point, +1 ! – Sergiy Kolodyazhnyy Aug 8 '16 at 17:09
  • 1
    Thanks! Worked for me to solve php repository issue. – Akash Agarwal Dec 17 '17 at 17:31
  • 1
    This answer solved my update for http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease – mvw Feb 21 '18 at 9:21
  • and quite possible, that you have not generated the key for your system before. therefore before following the above steps use - gpg --gen-key (references - packaging.ubuntu.com/html/getting-set-up.html) – parasrish May 9 '18 at 5:05

You need to get and import the key.

To get the key from a PPA, visit the PPA's Launchpad page. On every PPA page at Launchpad you will find this link (2), after clicking on 'Technical details about this PPA' (1):

image 1

Follow it and click on the key ID link (3):

image 2

Save the page, this is your key file.

Now it's time to import it:

  • Applications > Software Center,
  • Edit > Software sources...,
  • Enter your password,
  • Go to the Authentication tab and click on Import Key File..., finally
  • Select the saved key file and click on OK.
| improve this answer | |
  • 1
    Don't lost your time, see the answer bellow. – Felipe Oct 17 '11 at 9:06
  • 5
    @FelipeMicaroniLalli, the question was how to add a pubkey using the GUI, not the terminal, so this answer was perfect. – Chris Woods Jul 30 '13 at 14:24
  • It's much easier and faster now to do this with y-ppa-manager (also a gui application). See my answer below. – monotasker Dec 4 '13 at 15:53
  • 1
    OK, but what if the repository is not an ubuntu ppa. E.g. Intel run their own repository for video hardware drivers at download.01.org – mc0e May 20 '15 at 15:39
  • Great step-by-step guide, thanks very much! really helpful for some one who failed to add key via apt-key. – Roy Ling Nov 10 '15 at 1:35

apt can only handle 40 keys in /etc/apt/trusted.gpg.d . 41 keys and you will get the GPG error "no public key found" even if you go through all the steps to add the missing key(s).

Check to see if there are any unused keys in this file from ppa(s) you no longer use. If all are in use, consider removing some ppa(s) along with the corresponding keyfiles in /etc/apt/trusted.gpg.d

Furthermore, using

sudo apt-key adv

Is considered a security risk and is not recommended as you are "undermining the whole security concept as this is not a secure way of recieving keys for various reasons (like: hkp is a plaintext protocol, short and even long keyids can be forged, …)". http://ubuntuforums.org/showthread.php?t=2195579

I believe the correct way to add missing keys (for example 1ABC2D34EF56GH78) is

gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv 1ABC2D34EF56GH78
gpg --export --armor 1ABC2D34EF56GH78 | sudo apt-key add -
| improve this answer | |
  • 1
    I found it easier to just delete all keys from /etc/apt/trusted.gpg.d and then proceed to accepted answer askubuntu.com/a/386003/284664 – janot Feb 8 '15 at 18:22
  • @mchid Can you please quote a document/url that talks about this 41 keys limit ? – SebMa Mar 27 '19 at 2:54
  • @SebMa The link is posted in my answer and references a bug in Debian that was impacted by this limit. Here is an anchor to the actual post within the link which mentions this: ubuntuforums.org/showthread.php?t=2195579#post_message_12882784 I'm not sure if actual documentation exists on this but the number 40 may have been used because "40" translates to "a lot" in many different languages. – mchid Mar 27 '19 at 8:22
  • @SebMa However, the limit exists or did exist at the time of this answer and for some time after as well. I have personally experienced this 41 keys limit and have fixed it by deleting unused keys to add a new key when 40 keys already existed to avoid this error. – mchid Mar 27 '19 at 8:23
  • 1
    @SebMa no wiki.debian.org/SecureApt – mchid Mar 27 '19 at 15:20

There is a tiny script packaged in the WebUpd8 PPA which I'll link as a single .deb download so you don't have to add the whole PPA - which automatically imports all missing GPG keys.

Download and install Launchpad-getkeys (ignore the ~natty in its version, it works with all Ubuntu versions from Karmic all the way to Oneiric). Once installed, open a terminal and type:

sudo launchpad-getkeys

If you're behind a proxy, things are a bit more complicated so see this for more info

| improve this answer | |
  • 1
    It is indeed the way I do now, since I saw this program presented on your website. Nevertheless, the aim of the question was to know how to do it in a graphical way. – Agmenor Jun 5 '11 at 22:34
  • The launchpad-getkeys script is now integrated into the program Y-PPA-manager. launchpad.net/~webupd8team/+archive/y-ppa-manager – monotasker Dec 4 '13 at 15:41

I faced the same issue while installing Heroku. The link below solved my problem -


After fixing the NO_PUBKEY issue, the below issue remained

W: GPG error: xhttp://toolbelt.heroku.com ./ Release: The following signatures were invalid: BADSIG C927EBE00F1B0520 Heroku Release Engineering <release@heroku.com>

To fix it I executed the following commands in terminal:

sudo -i  
apt-get clean  
cd /var/lib/apt  
mv lists lists.old  
mkdir -p lists/partial  
apt-get clean  
apt-get update  

Source - Link to solve it

| improve this answer | |
  • I'm still getting same error, GPG error: http://download.opensuse.org/repositories/home:/colomboem/xUbuntu_16.04 Release: The following signatures were invalid: – Itamar Katz Apr 13 at 8:58

Make sure you have apt-transport-https installed:

dpkg -s apt-transport-https > /dev/null || bash -c "sudo apt-get update; 
sudo apt-get install apt-transport-https -y" 

Add repository:

curl https://repo.skype.com/data/SKYPE-GPG-KEY | sudo apt-key add - 
echo "deb [arch=amd64] https://repo.skype.com/deb stable main" | sudo tee /etc/apt/sources.list.d/skype-stable.list 

Install Skype for Linux:

sudo apt-get update 
sudo apt-get install skypeforlinux -y

Source: https://community.skype.com/t5/Linux/Skype-for-Linux-Beta-signatures-couldn-t-be-verified-because-the/td-p/4645756

| improve this answer | |

More generally, the following method should work for every repository. First of all search, with eventual help of a search engine, for a text on the program provider's website looking like the following:

Version: GnuPG v1.4.1 (GNU/Linux)

Such a text is for example displayed on http://deb.opera.com. Copy the passage, paste it in an empty file that you create on your desktop. This results in the key file.

Then continue with the importation of the key:

  • Applications > Sofware Center
  • Edit > Sofware sources..., enter password
  • Authentication tab, click on 'Import Key File...'
  • Select the saved key file and click on 'Ok'.

You may now remove the previously created key file.

| improve this answer | |

Good! I finaly found the way!

I've tested all method's to fix GPG error NO_PUBKEY and nothing working for me.

I've deleted the entire contents of the folder /etc/apt/trusted.gpg.d

cd /etc/apt/trusted.gpg.d
sudo rm -R *
sudo apt-get update

And I use the Y-PPA-Manager method because I'm too lazy to create all pubkey's manually (too many): http://www.unixmen.com/fix-w-gpg-error-no_pubkey-ubuntu/

run sudo apt-get update again and finaly all work great now! Tanks!

Based Source : post #17 on https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1263540

| improve this answer | |
  • This was the only thing that worked for me too. Presumably a corrupted keyfile somewhere? – donnek Apr 3 '18 at 7:33

I had the same problem with DynDNS's Updater client.

Turns out it was just expired keys.

Reinstalling the software (downloading a new .deb from the website, then using Software Centre to reinstall) fixed the problem.

Error message for reference:

W: GPG error: http://cdn.dyn.com stable/ Release: The following signatures were invalid: KEYEXPIRED 141943.......
| improve this answer | |

This error can also occur when the apt list file by the PPA points to a local keyring, like

deb [signed-by=/usr/share/keyrings/SOMETHING.gpg] https://download.something.org/something something/

And while that file may exist on your system (possibly downloaded with a prior command), it may be unreadable due to missing permissions. I just fixed this kind of error by running

chmod 644 /usr/share/keyrings/*

after having fetched the keyring file. The underlying issue was the usage of sudo when I already was root user. Really weird as all of this is root anyway and there was no access permission failure message anywhere... but that fixed it

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.