0

I'm trying to play Fallout 4, but this game using Intel video card. I can run everything i want with DRI_PRIME=1, and it will use AMD. But not Fallout -_-

So I think, that the problem with AMD driver (because it is the first recommendation in every second web-site, to upgrade the video-driver)

My system:

  • Ubuntu 20.04.1 LTS
  • Intel core i7 6820HQ
  • AMD Radeon HD 8750M
  • 16GB RAM

So...
I have 2 drivers installed (I think).
Here is the output of sudo lspci -v (The part with AMD)

01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8670A/8670M/8750M] (rev 81)
Subsystem: Dell Mars [Radeon HD 8670A/8670M/8750M]
Flags: bus master, fast devsel, latency 0, IRQ 132
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at ef200000 (64-bit, non-prefetchable) [size=256K]
I/O ports at e000 [size=256]
Expansion ROM at ef240000 [disabled] [size=128K]
Capabilities: [48] Vendor Specific Information: Len=08
Capabilities: [50] Power Management version 3
Capabilities: [58] Express Legacy Endpoint, MSI 00
Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010
Capabilities: [150] Advanced Error Reporting
Capabilities: [270] Secondary PCI Express
Kernel driver in use: radeon
Kernel modules: radeon, amdgpu

Here is the output of inxi -Ga

Graphics:
Device-1: Intel HD Graphics 530 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:191b Device-2: AMD Mars [Radeon HD 8670A/8670M/8750M] vendor: Dell driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:6600 Display: x11 server: X.Org 1.20.9 driver: none compositor: gnome-shell v: 3.36.4 tty: N/A
OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2)
v: 4.6 Mesa 21.0.0-devel (git-0399959 2021-01-06 focal-oibaf-ppa)
direct render: Yes

Kernel driver in use: radeon. So how to switch it to amdgpu?
And why the second command shows driver: none

Ask me, if you need the output of some command.

P.S. I saw the very similar questions, but it didn't help... (https://ask-ubuntu.ru/questions/491091/ya-dumayu-chto-ya-ispolzuyu-radeon-vmesto-amdgpu-kak-ya-mogu-izmenit)

0

The tread can be closed. I found an answer.

You just need to update the grub according to your video card.

First step:

There is a two option:

  • First is Sea Island (Southern Islands) (Radeon HD 7000 and 8000 series)
  • And the second is Caribbean Islands (Radeon Rx 300 series)

For more details visit
Sea Islands (https://en.wikipedia.org/wiki/Radeon#Southern_Islands)
Caribbean Islands (https://en.wikipedia.org/wiki/Radeon#Caribbean_Islands)

Second step:

You sould open terminal and type next command:
sudo nano /etc/default/grub

Then edit GRUB_CMDLINE_LINUX_DEFAULT according to the first step.

For the Sea Island the value of GRUB_CMDLINE_LINUX_DEFAULT should be radeon.si_support=0 amdgpu.si_support=1

And for the Caribbean Islands it sould be radeon.cik_support=0 amdgpu.cik_support=1

So the final string should looks like:
GRUB_CMDLINE_LINUX_DEFAULT="radeon.si_support=0 amdgpu.si_support=1"

When you finish editing press ctrl+x and type "y" to accept the editing.

Third step

Use command update-grub or update-grub2 and reboot using reboot command

THAT'S ALL.

It didn't worked for me because I had unwanted arguments (don't remember which one, but it started like amd.*)

Wish you luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.