1

I'm using Ubuntu Desktop 20.04.1 LTS.

The desktop GUI (GNOME Shell I believe) was working fine this morning. After updating and installing some new hardware the desktop GUI became unresponsive when trying to launch an app and is displaying weird UI glitches.

These are the steps that I took just before things went strange:

  1. sudo apt update && sudo apt upgrade
  2. Ran Software Update application
  3. Installed a PCIE NVME+SATA M.2 ADAPTER with a M.2 SATA drive

After booting up and logging in I tried to launch the Disks application. The app didn't launch and the desktop GUI became unresponsive and kind of visually crashed. I could still move the mouse pointer but clicking did nothing. App icons appeared diagonally across the desktop and the dock on the left started to wiggle.

I resorted to powering off the computer. I then removed the PCIE NVME+SATA M.2 ADAPTER and powered back on. However the GUI issues reappeared as soon as I tried to launch the Terminal app.

I was able to SSH into the computer and run sudo apt install --reinstall gnome-shell but this hasn't resolved the strange GUI issues.

Also the following didn't fix the issue but now the dock has disappeared:

sudo apt purge gnome-shell
sudo apt install gnome-shell

Other processes, Plex for example, are running fine. The issue seems to only be with the desktop GUI.

Below is the update history from the update I did right before the issue started:

Commandline: apt upgrade
Requested-By: matthew (1000)
Install: libllvm11:amd64 (1:11.0.0-2~ubuntu20.04.1, automatic)
Upgrade: libdrm-nouveau2:amd64 (2.4.101-2, 2.4.102-1ubuntu1~20.04.1), xserver-common:amd64 (2:1.20.8-2ubuntu2.6, 2:1.20.9-2ubuntu1.1~20.04.1),
 libegl1:amd64 (1.3.1-1ubuntu0.20.04.1, 1.3.2-1~ubuntu0.20.04.1), xserver-xorg-core:amd64 (2:1.20.8-2ubuntu2.6, 2:1.20.9-2ubuntu1.1~20.04.1),
libegl-mesa0:amd64 (20.0.8-0ubuntu1~20.04.1, 20.2.6-0ubuntu0.20.04.1), update-notifier-common:amd64 (3.192.30, 3.192.30.3), libgl1:amd64 (1.3.
1-1ubuntu0.20.04.1, 1.3.2-1~ubuntu0.20.04.1), libglapi-mesa:amd64 (20.0.8-0ubuntu1~20.04.1, 20.2.6-0ubuntu0.20.04.1), google-chrome-stable:amd
64 (87.0.4280.88-1, 87.0.4280.141-1), xserver-xorg-legacy:amd64 (2:1.20.8-2ubuntu2.6, 2:1.20.9-2ubuntu1.1~20.04.1), libxatracker2:amd64 (20.0.
8-0ubuntu1~20.04.1, 20.2.6-0ubuntu0.20.04.1), libgles2:amd64 (1.3.1-1ubuntu0.20.04.1, 1.3.2-1~ubuntu0.20.04.1), libgbm1:amd64 (20.0.8-0ubuntu1
~20.04.1, 20.2.6-0ubuntu0.20.04.1), xserver-xephyr:amd64 (2:1.20.8-2ubuntu2.6, 2:1.20.9-2ubuntu1.1~20.04.1), libdrm-amdgpu1:amd64 (2.4.101-2,
2.4.102-1ubuntu1~20.04.1), xwayland:amd64 (2:1.20.8-2ubuntu2.6, 2:1.20.9-2ubuntu1.1~20.04.1), libdrm2:amd64 (2.4.101-2, 2.4.102-1ubuntu1~20.04
.1), libglx0:amd64 (1.3.1-1ubuntu0.20.04.1, 1.3.2-1~ubuntu0.20.04.1), libgl1-mesa-dri:amd64 (20.0.8-0ubuntu1~20.04.1, 20.2.6-0ubuntu0.20.04.1)
, libdrm-intel1:amd64 (2.4.101-2, 2.4.102-1ubuntu1~20.04.1), libdrm-radeon1:amd64 (2.4.101-2, 2.4.102-1ubuntu1~20.04.1), linux-firmware:amd64
(1.187.6, 1.187.7), mesa-vulkan-drivers:amd64 (20.0.8-0ubuntu1~20.04.1, 20.2.6-0ubuntu0.20.04.1), update-notifier:amd64 (3.192.30, 3.192.30.3)
, libglx-mesa0:amd64 (20.0.8-0ubuntu1~20.04.1, 20.2.6-0ubuntu0.20.04.1), libglvnd0:amd64 (1.3.1-1ubuntu0.20.04.1, 1.3.2-1~ubuntu0.20.04.1), li
bdrm-common:amd64 (2.4.101-2, 2.4.102-1ubuntu1~20.04.1)
End-Date: 2021-01-07  14:00:58

I can provide the full boot log if that will help. The following lines at the top seem a bit strange:

Volume group "vgubuntu" not found
Cannot process volume group vgubuntu

Any help would be most appreciated. Many thanks.

Update: This many be some kind of rendering issue. For example if I open the Terminal app the Terminal window does not appear but the mouse pointer does change to a cursor when hovering over the area of the desktop where the terminal window should be.

1

So... I found someone with a similar issue.

Using dmesg | grep GPU I confirmed my issue is indeed a GPU hang.

[  980.100449] i915 0000:00:02.0: [drm] GPU HANG: ecode 7:1:85ddfffd, in Xorg [3664]
[  980.204709] i915 0000:00:02.0: [drm] Xorg[3664] context reset due to GPU hang

As a temporary solution, until the Intel drivers have been updated, I've added nomodeset to my Grub configuration. Relevant instructions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.