I have an Ubuntu 20.04 system that I have been using with no problem for well over a year. I dual boot this computer between Linux and Windows. In case this information is useful the video card is an nVidia GTX-1070.

Today I rebooted from Linux into Windows and then back into Linux about an hour later. When my machine started it took longer than normal but eventually did bring me into a login window, however I'm stuck at 640x480. If I log in there are no other resolutions available. Also, when I shut down or restart the computer, about 8 times out of 10 it hangs and I have to hold the power button in.

If I boot into Windows everything works perfectly so it does not seem like a hardware problem.

I would really appreciate any pointers anyone could provide because I'm a bit desperate to get this working again, I spend most of my time in Linux and use it for work and really don't have time to do a clean reinstall right now.

Thanks in advance.

  • 1
    How did you install the NVIDIA drivers into your Ubuntu? If you didn't use the graphics-drivers PPA, the driver from NVIDIA themselves does not install a DKMS (Dynamic Kernel Module Support) driver that allows for carry over into the next kernel update. There have been at least 2 kernel updates / upgrades over the last couple of days. 5.4.0-58 was updated to 5.4.0-59 and if you had the HWE installed it was upgraded to 5.8.0-34.
    – Terrance
    Jan 7, 2021 at 22:17
  • Thank you. I discovered that if I boot into grub and select kernel version 5.4.0-59-generic that everything works fine. So you are almost certainly right that this was the result of a kernel upgrade to 5.8.0-34.
    – Gabs
    Jan 7, 2021 at 23:32
  • If the NVIDIA DKMS driver was installed it would have updated the driver into the 5.8.0-34 kernel as well. When you are in the 5.4.0-59 kernel if you type in dkms status it should show you any drivers that are using DKMS. If you don't see any, then the NVIDIA driver from the graphics-drivers PPA was not installed.
    – Terrance
    Jan 7, 2021 at 23:45
  • The easiest soulution will be to remove the 5.8 kernel.
    – Pilot6
    Jan 8, 2021 at 9:58

1 Answer 1


I just experienced the same problem after upgrading to 5.8.0-36-generic this morning.

I installed the NVIDIA driver manually using the terminal some 5 months ago.

The quickest solution is so go to 'Software & Updates', click on 'Additional Drivers' and install the desired driver there.

(Can't say if this works for everybody)

  • Same solution worked for me just now. Ubuntu software update did something to mess up the graphics. NVIDIA graphics card was using some other driver. Picked "nvidia-driver-470 (proprietary, tested)", click "Apply Changes". Ubuntu prompts you to boot after install. Graphics worked after reboot.
    – Hammurabi
    Nov 25, 2021 at 17:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .