2

Recently, external microphone has stopped working while using classic wired audio combo jack headset.

And worse, I've tried now fresh Ubuntu 20.10 USB live, and not working, either.

Basics:

  1. Headset's microphone works fine both in MS Windows on the same machine and on older Xubuntu on another machine.
  2. Internal laptop mic works normally.
  3. Yes, I have mic unmuted in settings.

Strange observations:

  1. there is only one profile in pavucontrol: pavucontrol only one profile whereas on my older machine with Xubuntu there are many more and I had been used to switch between "Analog Stereo Duplex" and "Analog Stereo output" to actually mute all mics in a convenient way.

  2. There is no [on] or [off] in amixer by the external microphone:

$ amixer -c 0 | grep -iA6 mic
Simple mixer control 'Dmic0',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 70
  Front Left: Capture 63 [90%] [13.00dB] [off]
  Front Right: Capture 63 [90%] [13.00dB] [off]
Simple mixer control 'Dmic1 2nd',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 70
  Front Left: Capture 65 [93%] [15.00dB]
  Front Right: Capture 65 [93%] [15.00dB]
Simple mixer control 'PGA1.0 1 Master',0

-- these [[on|off]] change properly on un/muting in the internal's mic Sound settings: un/muting in sound settings unmuting2

What does not work: This recommendation (killall pulseaudio && pulseaudio -k && rm -r ~/.config/pulse/* ; rm -r ~/.pulse* ; sleep 10 && reboot) from help.ubuntu.com has not helped.

Hardware and OS info:

$ lspci | grep -i audio
00:1f.3 Multimedia audio controller: Intel Corporation Smart Sound Technology Audio Controller (rev 30)
$ sudo lshw | grep -C6 "00:1f.3"
             configuration: latency=0
        *-multimedia
             description: Multimedia audio controller
             product: Smart Sound Technology Audio Controller
             vendor: Intel Corporation
             physical id: 1f.3
             bus info: pci@0000:00:1f.3
             version: 30
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi bus_master cap_list
             configuration: driver=sof-audio-pci latency=32
             resources: irq:186 memory:9c4b4000-9c4b7fff memory:9c200000-9c2fffff
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.10
Release:    20.10
Codename:   groovy
$ uname -oipmvr
5.8.0-34-generic #37-Ubuntu SMP Thu Dec 10 18:01:14 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
$ cat /proc/asound/card*/codec* | grep Codec
Codec: Realtek ALC295
Codec: Intel Icelake HDMI

How to fix this?

I believe the very same headset used to work just fine in 20.04. What to do, please?

4
  • I've just executed the whole thing in Step 1, no luck, microphone still not working. And moreover, it is not working even with my Bluetooth headset, which used to work before at least :( What to do? I hope and believe complete reinstall is not necessary...
    – crysman
    Jan 16 '21 at 10:37
  • there is also a bugreport by me at launchpad: bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1912052
    – crysman
    Jan 23 '21 at 11:01
  • I've made another link here: bugzilla.kernel.org/show_bug.cgi?id=195457
    – crysman
    Jan 23 '21 at 14:30
  • Hello @crysman and any other user that is affected by this, I have built some test kernels in bug 1912052. However I don't have this HW, it will be great if you can help on testing this. Thanks!
    – P.-H. Lin
    Nov 25 '21 at 2:51
0

For my SPIN 5 (SP513-52N) it was enough to combine this and this. So I put the following into /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel model=alc255-acer

This works although the Spin 5 uses an ALC295 (and not ALC255). Now when I plug something into the audio jack I get asked, if it is 'Headphones' or 'Headset'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.