0

The error: NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
Prerequisites: Everything was fine yesterday, I didnt install any drivers or updates
A problem: I have bad screen resolution 640x380
Current OS is: Ubuntu 20.04.1 LTS
GPU: geforce gtx 1080
nvidia driver is: 455
cuda is 11.1: but i didnt touch any settings related to it more than a few weeks, so it couldn`t affect it, because i switched on and restarted my PC for many times after installing it and there is not any problems
What I have done to try to fix it:

1)

sudo apt update -y
sudo apt upgrade -y
sudo reboot now
sudo prime-select intel
sudo prime-select nvidia
# i didnt have /lib/modprobe.d/blacklist-nvidia.conf 
# so i wasnt able to delete it
sudo update-initramfs -u
sudo reboot now
  1. I have disabled the security boot in my bios
  2. Tried to install again, but it was written: "I have the latest version"
sudo ubuntu-drivers autoinstall

Any thoughts?

8
  • 1
    Did your kernel update to 5.8.0-34-generic yesterday? If so, chances are your NVIDIA driver was installed from NVIDIA themselves and not the graphics-drivers PPA which doesn't install the DKMS driver version that will carry over into the new kernel. Any kernel updates when using the proprietary driver from NVIDIA will have to be reinstalled after the kernel update.
    – Terrance
    Commented Jan 7, 2021 at 14:45
  • @Terrance Hi As I wrote above I didnt do any updates/installations explicit by hand yesterday. May the os do it automatically? If so how can I check it? My kernel version now is uname -r -> 5.4.0-59-generic Thanks Commented Jan 7, 2021 at 14:56
  • Try booting to your previous kernel of 5.4.0-58-generic and see if the driver still works there. You may not have the HWE kernel installed which bumps up to 5.8.0-34-generic, but the CUDA installation that installs its own driver does not install the DKMS driver that carries over into the new kernel. I have seen this many times on here.
    – Terrance
    Commented Jan 7, 2021 at 14:59
  • @Terrance Yes, it works with 5.4.0-58-generic, thanks. What should I do now? Commented Jan 7, 2021 at 15:19
  • I actually just updated my answer here askubuntu.com/a/1288405/231142 on how to install CUDA 11.2 with using the graphics-drivers PPA along with it so that you don't bump into driver issues after kernel updates. Take a look.
    – Terrance
    Commented Jan 7, 2021 at 15:20

1 Answer 1

1

I had exactly the same problem but it's been fixed in today's update.

Just update and it will be solved

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .