6

After yesterday upgrade with command

sudo apt-get -y --with-new-pkgs upgrade

i have Dummy Output in Output Device and now i hear no sound, either through speaker or audio jack.

i have new kernel 5.8.0-34

inxi -SA output is:

System:    Host: matteo-swift Kernel: 5.8.0-34-generic x86_64 bits: 64 Desktop: Gnome 3.36.4 
           Distro: Ubuntu 20.04.1 LTS (Focal Fossa) 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: N/A
           Sound Server: ALSA v: k5.8.0-34-generic 

it seems that audio driver is missing (driver: N/A) but i can't find it online

pulseaudio -vvv output is:

I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: RealtimeKit worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 13.99.1
D: [pulseaudio] main.c: Compilation host: x86_64-pc-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -g -O2 -fdebug-prefix-map=/build/pulseaudio-fQvFZE/pulseaudio-13.99.1=. -fstack-protector-strong -Wformat -Werror=format-security -Wall -W -Wextra -pipe -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -fno-common -fdiagnostics-show-option -fdiagnostics-color=auto
D: [pulseaudio] main.c: Running on host: Linux x86_64 5.8.0-34-generic #37~20.04.2-Ubuntu SMP Thu Dec 17 14:53:00 UTC 2020
D: [pulseaudio] main.c: Found 8 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Running from build tree: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
I: [pulseaudio] main.c: Machine ID is e792d386e07a415da8d95fabe1e536a4.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/matteo/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-13.99.1/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

alsamixer output is (same with parameter -c 1,2,3....):

cannot open mixer: No such file or directory

i had alredy tried solutions of these posts:

No sound on Ubuntu 20.04

Only "Dummy output" (sound) in Ubuntu 20.04 after reboot - Broken driver / module

2
1

Not a fix, but a workaround : if you still have the previous kernel image (5.4.0-59 in my case), you can boot with it by selecting it from the Grub menu. As a bonus, it also solves the Bluetooth issue.

By chance, I didn't run apt autoremove...

D.

1
  • sudo apt autoremove don't delete the previous kernel. So even if you had run that comand, you will still be able to boot back on previous kernel. – Soren A Jan 8 at 15:24
1

Not a solution.

I'm facing the same issues after kernel update today in Kubuntu. Rolling back the old kernel was the only solution to make things work again, but i'm giving up to Kubuntu. In other distro this problem existed only with Nvidia CUDA if install Kernel 5.9 while in Kubuntu upgrading to 5.4.0.60 or 5.8 which are older kernel is a little weird.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.