0

I have tried multiple solutions I found online to solve this. I installed Ubuntu 20.04 LTS alongside Windows 10 and upon reset after successful installation, windows loads automatically.

Ubuntu does not show up in the boot order when trying to configure the UEFI.

One of the solutions I tried was using boot repair, which gave me the following logs (second one after reinstalling and failing again):

https://paste.ubuntu.com/p/WZxmwQcX5k/

https://paste.ubuntu.com/p/cngdz8z6BK

The steps in this thread (How to get GRUB to be the default bootloader instead of Windows Boot Manager on a UEFI laptop?) did not help.

I was using the following guide for the installation: ( https://itsfoss.com/install-ubuntu-1404-dual-boot-mode-windows-8-81-uefi/ ) so the instructions vary slightly but many milestones were the same. At step 6 I do not have grub showing up or do not know how to access it. Also I see no proper option to point to a specific efi file.

Would really appreciate some guidance.

EDIT: what worked out for me:

  1. uninstalled ubuntu by deleting partitions through Windows Disk Manager
  2. instead of using the windows Advanced Restart to boot on Live USB for installation, I pressed esc during startup and forced boot on the Live USB (I had 2 options, chose UEFI one)
  3. live ubuntu interface was different, but I just went for installing it alongside windows without creating the partitions manually.
  4. upon completion and restart, grub worked.
8
  • 2
  • @karel thanks for answering. I was using the following guide for the installation: ( itsfoss.com/… ) so the instructions vary slightly but many milestones were the same. The link you referred to did not help me as at step 6 I do not have grub showing up or do not know how to access it. Also I see no proper option to point to a specific efi file. – canadianrooster Jan 7 at 13:59
  • What's the use of complaining that the link didn't work if you only tried one answer of five answers on that page? – karel Jan 7 at 14:03
  • @karel that was just my unfamiliarity with the page design. I will look at the others and provide feedback. – canadianrooster Jan 7 at 14:26
  • You installed in BIOS/Legacy/CSM mode and now have a grub boot loader in gpt's protective MBR. Your Windows is UEFI and you should install in UEFI boot mode. If you boot live installer in UEFI mode & run Boot-Repair you should install the UEFI version of grub & convert install to UEFI. help.ubuntu.com/community/UEFI Shows Windows screens askubuntu.com/questions/221835/… Make sure Windows fast start up is off & that Windows is seen, otherwise installer may erase Windows. And always have good backups. – oldfred Jan 7 at 14:47
0
  • boot in live Ubuntu pendrive.
  • run terminal and paste the following command.
 sudo update-grub 

This command update pre-installed grub also.

I hope your problem solved.

5
  • hi @kaushaul, thanks for answering. it does not. My problem is not seeing grub to begin with - system boots directly to windows. the only ubuntu i can boot is the live version on the flashdrive. – canadianrooster Jan 7 at 14:00
  • maybe this help. you can try the same thing with a live usb. it also works for pre-installed grub. – Kaushal Bhatol Jan 7 at 14:09
  • unfortunately i have tried that from the live ubuntu in a few attempts of reinstalling grub. Still can't get it to show up on my boot options. – canadianrooster Jan 7 at 14:35
  • You cannot mix BIOS install & UEFI installs. UEFI & BIOS are not compatible and once you start booting in one mode you cannot switch. Or grub can only boot other installs in same boot mode. Some boot managers if booted in UEFI mode can use UEFI's one time reboot feature to reboot into a BIOS install. But best to have all installs in UEFI boot mode. How you boot install or repair media UEFI or BIOS is then how it repairs, so always boot in UEFI mode. – oldfred Jan 7 at 14:51
  • @oldfred You are absolutely right. I also using Ubuntu and Windows 10 both OS in UEFI boot ordered, I never face any problem. – Kaushal Bhatol Jan 7 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.