0

After upgrade from ubuntu mate 16.04 I have troubles with adding extra keyboard layouts in my ubuntu mate 20.04
I have 2 partitions: /home and /
/home is living with my installations since ubuntu 10.10
/ is reformatted all times after ubuntu upgrade
I'm simply not able to add any layouts.
If I try to add in keyboard settings new keyboard, this window freezes.
When i start mate-keyboard-properties from terminal and try to add keyboard,i'm getting following message in terminalError

Keyboard preferences window freezes and does not response on any other clicks.
Is it problem with my older configs from previous installations?
How can i repair it?

UPD
New user is able to add layouts for his session.
It is not working for my user.

6
  • Can you create an additional user for test purposes and let us know if keyboard layout management works as expected for that user. – Gunnar Hjalmarsson Jan 7 at 9:37
  • It is working fine with test user – UNIm95 Jan 7 at 18:43
  • That confirms that the problem lies in your $HOME and that the suggestion in da_kingpin's answer is a reasonable approach. Personally I would try to move away ~/.cache also. – Gunnar Hjalmarsson Jan 7 at 20:47
  • Suggestion of @da_kingpin is bit overkill. I would like to restrict this changes only to mate settings and not for all settings of all my applications. – UNIm95 Jan 8 at 8:30
  • Then you probably need a MATE expert. If you are lucky some of those sees this, but you may want to also try ubuntu-mate.community – Gunnar Hjalmarsson Jan 8 at 23:20
0

If you have been carrying your /home directory since 10.10 then yes, it may be time to remove some old config files in your home dir. Most applications store config files in your home directory in the ~/.config folder, or in their own respective hidden directory ~/.<application-name> .

Be sure to backup any files before making changes. And as a precaution have a live image available.

To list your hidden files and directories from terminal ls -ld .?*

Most application will rebuild default config settings when reopened after removing the config directory.

DICLAIMER Not responsible for anything. Proceed at your own risk!!! DISCLAIMER

Now with that out of the way, it is really not that bad.

Since you have been a user since 10.10, I presume you are an experience user.

From terminal mv ~/.config ~/.config.backup or

mv ~/.<application> ~/.<application>.backup

logout, then login.

It will take some time for the default desktop config files to be reinstalled. If there are any problems you can reboot into a LiveImage or using a recovery mode menu entry from grub and simply move the backup copy you previously made back by

mv /home/<your-dir>/.config.backup /home/<your-dir>/.config

2
  • I think that it bit overkill. Remove all settings of all apps. I think that it should be connected only to mate/gnome2 settings. – UNIm95 Jan 7 at 5:44
  • You are correct. It is overkill. That is why I suggested backing up the .config folder first. Over time many setting and configurations can be changed with conflicting configurations set. So this is recommended as a troubleshooting first step. Just to determine if a configuration is the culprit. You could then begin to narrow it down as necessary. I should have been more detailed in that suggestion I suppose. – da_kingpin Jan 7 at 5:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.