0

I already managed to install Ubuntu 20.04 along with Windows 10 on my new PC. I have two SSD drives: one NVMe M.2 and one SATA 3, and both systems are installed on the former drive. The 2-TB SATA SSD only serves as a data drive. On Windows, I can access all the files and data on this drive without any problems. But the Ubuntu system can't recognize it -- specifically, the drive can be detected but the file system is "unknown" when viewed on GParted. Excepted for this strange issue, Ubuntu works just fine. How can I access this drive on Ubuntu without destroying (or formatting) the data?

Here's the background information about my system settings:

  • The fast boot settings (either the fast startup on Windows or fast boot on BIOS) are off after I started to install Ubuntu, as checked just now.
  • The SATA configuration is set to AHCI on BIOS.
  • This drive, when viewed on Windows, is NTFS, has only one partition (basic), and does not show any errors that need to be checked.

Here is the output of lsblk. The sda drive is what I am talking about. I noticed that both sda1 and sda2 don't have an NTFS label. On the other hand, the Windows system partition is nvme0n1p4 which is mountable.

whyj@WhyJ-Ubuntu:~$ lsblk -o NAME,FSTYPE,LABEL,SIZE,MOUNTPOINT
NAME        FSTYPE   LABEL      SIZE MOUNTPOINT
loop0       squashfs             91M /snap/core/6350
loop1       squashfs          140.7M /snap/gnome-3-26-1604/100
loop2       squashfs          140.7M /snap/gnome-3-26-1604/74
loop3       squashfs           97.9M /snap/core/10577
loop4       squashfs           64.8M /snap/gtk-common-themes/1514
loop5       squashfs            3.7M /snap/gnome-system-monitor/57
loop6       squashfs           55.4M /snap/core18/1944
loop7       squashfs            2.2M /snap/gnome-system-monitor/148
loop8       squashfs          217.9M /snap/gnome-3-34-1804/60
loop9       squashfs             51M /snap/snap-store/518
loop10      squashfs           34.6M /snap/gtk-common-themes/818
sda                             1.8T 
├─sda1                           16M 
└─sda2                          1.8T 
nvme0n1                       931.5G 
├─nvme0n1p1 ntfs     Recovery   529M 
├─nvme0n1p2 vfat                 99M /boot/efi
├─nvme0n1p3                      16M 
├─nvme0n1p4 ntfs              465.1G /media/whyj/B6E83AA2E83A6133
└─nvme0n1p5 ext4              465.8G /

And here's the output of sudo file -s /dev/sda{,1,2}:

whyj@WhyJ-Ubuntu:~$ sudo file -s /dev/sda{,1,2}
/dev/sda:  DOS/MBR boot sector; partition 1 : ID=0xee, start-CHS (0x0,0,2), end-CHS (0x20,254,63), startsector 1, 4294967295 sectors, extended partition table (last)
/dev/sda1: data
/dev/sda2: data

I also tried manually mounting the drive, but it always show this error message:

whyj@WhyJ-Ubuntu:~$ mkdir ~/ddrive
whyj@WhyJ-Ubuntu:~$ sudo mount -t ntfs /dev/sda2 ~/ddrive
NTFS signature is missing.
Failed to mount '/dev/sda2': Invalid argument
The device '/dev/sda2' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

It shows the same output even I change -t ntfs to -t ntfs-3g or -t auto. I tried to mount /dev/sda as a whole with no luck. Any ideas/solutions would be much appreciated.

12
  • 1
    Turn off Windows "Fast Boot".
    – waltinator
    Jan 5 at 19:38
  • The fast boot is always off after I started to install Ubuntu, and actually Ubuntu works fine except for this strange issue.
    – WhyJ
    Jan 5 at 19:52
  • What does sudo file -s /dev/sda{,1,2} show? Please edit your post to add new information, properly formatted. Information added via comments is hard for you to format, hard for us to read and ignored by future readers. Please click edit and add that vital information to your question so all the facts we need are in the question. Please don't use Add Comment, since that's our uplink to you. All facts about your system should go in the Question with edit
    – waltinator
    Jan 5 at 20:02
  • Thanks waltinator for the suggestion. The original post has been updated with new info.
    – WhyJ
    Jan 5 at 20:16
  • Note that Windows updates often turn fast start up back on. So just booting into Windows may change setting & updates are usually in background. Is drive set for AHCI? But most systems do not have separate settings by drive. If NTFS does it need chkdsk, that also can cause issues mounting from Linux.
    – oldfred
    Jan 5 at 20:21
0

I eventually solved this by formatting the data disk as NTFS again. Magically, Ubuntu recognizes it at this time. This is not exactly the method I was hoping to get because I had to spend some time moving the data in and out, but it did work for me!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.