I tried to install Ubuntu 20.04 dual boot with Windows 10 on My UH-X. I found that

  1. The touchpad can work properly on Windows 10.
  2. I run Ubuntu 20.04 kernel 5.10.4 and tried to check with xinput command. It's not shown the touchpad in the list. xinput_Fujitsu UH-X
  3. I tried to edit grub as the recommend in ask.ubuntu which they claimed that can solved this problem in previous medel but it's not work in UH-X. grub editor

Please help me solve this problem?

3 Answers 3


That's what worked for me.

  1. Load Terminal with Ctrl-Alt-T
  2. sudo apt install xserver-xorg-input-synaptics
  3. sudo reboot
  4. sudo modprobe i2c_hid

It started working right after 4), not sure if steps 2 and 3 were even necessary. Also I have to run 4) every time I log in, adding it to start-up scripts doesn't work for some reason

  • Just running the 4th modprobe command is enough for Ubuntu 20.04.2
    – HugoTai
    Sep 23, 2021 at 17:03
  • Well, they broke it completely in 21. I'm on 21.10 atm and there's just no way to revive the trackpad. I filed a bug in the Ubuntu bug tracker months ago, zero feedback so far Mar 10, 2022 at 2:45
  • did u try sudo modprobe i2c-hid-acpi said by @user1544291
    – HugoTai
    Mar 10, 2022 at 6:43
  • Also want to ask, is sleep mode working? my UH-X is U9311 btw
    – HugoTai
    Mar 10, 2022 at 9:42
  • Yay! It works indeed. Thank you! I missed that answer. Sleep mode works, but only one way :) I close the lid, it goes to sleep and never comes back. Sometimes the screen flashes for a split second, but it never goes back to life completely Mar 10, 2022 at 10:07

For ubuntu 21.10 and Fujitsu Lifebook UH,

sudo modprobe i2c_hid

did not work, but

sudo modprobe i2c-hid-acpi



Insert this line in /etc/modules:


That way, the module is launched at boot automatically.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .