0

I am working with Ubuntu 18.04 on dual boot and I am trying to increase my home partition using gparted.

My home partition is /dev/sda9 and drive letterE: is on the /dev/sda6 partition. It has almost 400 GB not used. I want to add 100GB to my home partition.

I tried to boot Ubuntu from USB and I shrinked the /dev/sda6 partition and know I have 100 GB of unallocated space, but I couldn't resize my home partition. How to do this?

screenshot of gparted

3
  • 2
    Does this answer your question? How to resize partitions?
    – Pilot6
    Jan 4, 2021 at 14:37
  • 1
    Live installer also often mounts swap, little key icon shows it mounted. You have to use live installer but then swap off or unmount the swap partition. Be sure to have good backups as any interruption of a partition move will leave system corrupted.
    – oldfred
    Jan 4, 2021 at 15:20
  • thank you for helping
    – mina
    Jan 4, 2021 at 15:54

1 Answer 1

3

Obviously you can't extend /dev/sda9 because /dev/sda7 and /dev/sda8 are on the way to the unallocated space.

Right click the swap partition and disable swap for a while. Then move the swap partition to the left.

Then move /dev/sda8 to the left.

After that you'll be able to extend the /dev/sda9 partition.

But beware that if you move the / partition, you'll have to reinstall grub.

To fix the boot issue, run:

sudo mount /dev/sda8 /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys  /mnt/sys
sudo chroot /mnt
sudo update-grub
exit

Reboot.

5
  • 1
    thank you , but how I move a partiton to the left? and I have to do this while booting from the usb ?
    – mina
    Jan 4, 2021 at 14:33
  • 1
    You can move partitions with a mouse. You need to do it after you boot from a USB.
    – Pilot6
    Jan 4, 2021 at 14:34
  • thank you , it worked for me and thank god i didn't lost my data. but now it boots to ubuntu and with version of kernel that I don't want to boot into it, I don't have anymore the bootloader window (the grub window .. ) to let me chose which os I want. how to make it appear again ? I tried to press esc but it didn't show the option advanced option for ubuntu
    – mina
    Jan 4, 2021 at 15:50
  • You can ask another question about it. It is easy to fix.
    – Pilot6
    Jan 4, 2021 at 22:17
  • actually I just updated grub again and it fixed it sudo update-grub , thank you
    – mina
    Jan 5, 2021 at 11:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .