0

I am currently running Ubuntu 20.04.1 on an Asus laptop. After I upgraded from 18.04, I installed the correct printer and scanner drivers for my Brother MFC-J805DW. I have no issues with printing. (Everything is on a wireless WAN, and I have no problems with any other devices on the network.)

However, I continue to have communication issues with scanning.

For example, yesterday, I completely uninstalled all Brother drivers, disabled Ubuntu autofinding printers, installed scanner and printer drivers I downloaded from the Brother website. I was able to successfully scan yesterday. (I use gscan2pdf.)

However, today when I tried to scan, I was unable to set the document size in gscan2pdf—nothing appears in the Geometry tab in gscan2pdf. (This has happened before.) So I scanned my document in the default size, which appears to be legal size.

Without closing gscan2pdf I tried to scan a second document. Suddenly, I got a "scanimage: open of device brother4:net1;dev0 failed: Invalid argument" error message. (This has also happened before. I change nothing, and suddenly my computer can't communicate with my scanner.)

What has worked in the past is to reinstall the scanner driver. I then run brsaneconfig4 -a name=Pete model=MFC-J805DW ip=13.13.1.21 to add a network entry. (Yes, my scanner is named Pete. I got tired of just calling it "Scanner".)

When I run scanimage -L I get the following output:

device `brother4:net1;dev0' is a Brother Pete MFC-J805DW
device `escl:http://13.13.1.21:80' is a ESCL MFC-J805DW flatbed scanner
device `net:localhost:brother4:net1;dev0' is a Brother Pete MFC-J805DW

Running dpkg -l | grep Brother shows that the driver is installed:

ii  brscan4                0.4.9-1    amd64   Brother Scanner Driver
ii  hll2370dwpdrv:i386     4.0.0-1    i386    Brother HL-L2370DW printer driver (lpd/cups)
ii  mfcj805dwpdrv:i386     1.0.5-0    i386    Brother Inkjet Printer Driver 

Now when I open gscan2pdf, I get three different scanners showing up. However, the Geometry tab is completely blank no matter which scanner I select.

I was able to scan using the first scanner listed in the above list, but again, it automatically defaulted to legal size, and I cannot set a different size.

My main question is, does anybody know what is happening here? Why does my computer lose connection with my scanner? How can I set this up so that I can communicate with it enough to tell it what size my paper is?

(On a side note, if somebody could tell me what an ESCL scanner is, I would pay good money to see that post. U of Google has remarkably little to say about it. And if I could add that as a tag here I would, but I don't have the required reputation, alas.)

1
  • 1
    Don't know what good money is (maybe not as phony as a two dollar bill) or how you would pay over the internet, but this answers part of your question: eSCL is also known as Apple AirScan or AirPrint scanning. It was promoted by Apple as a way of scanning from a mobile device and any device that supports AirPrint version 1.4 should support eSCL.Oct 4, 2020 SaneOverNetwork - Debian Wiki Jan 4, 2021 at 2:00

1 Answer 1

0

Uninstall the Brother drivers and use the sane-airscan backend. It will support eSCL mode on your scanner.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.