It's really dizzying. I seem to have java installed (using the script from https://github.com/flexiondotorg/oab-java6 ) however when I connect I see the java "Launching netconnect, this may take several minutes." This finishes but netconnect doesn't actually seem to be running.

I've managed to get this working with previous versions of Ubuntu, so I think I know what should happen.

  • As an update, this: askubuntu.com/questions/126682/… worked for me, specifically: sudo apt-get remove firefox openjdk-6-jdk icedtea-6-plugin & sudo apt-get install firefox:i386 openjdk-6-jdk:i386 icedtea-6-plugin:i386, however I had previously tried so many things that I can't really provide a step-by-step.
    – JIm
    May 23, 2012 at 12:42
  • I'm not clear where Citrix comes into play here.
    – belacqua
    Jun 19, 2012 at 18:00

2 Answers 2


I can't answer your question for Citrix, but I can answer it for Juniper VPN from a fresh installation of Ubuntu 12.04. Two solutions depending on whether you have a 32 or 64 bit installation, tested using Live CDs:


sudo apt-get remove firefox openjdk-6-jdk icedtea-6-plugin
sudo apt-get install firefox:i386 openjdk-6-jdk:i386 icedtea-6-plugin:i386

Run Firefox, and log into your VPN.


sudo apt-get install openjdk-6-jdk icedtea-6-plugin

Run Firefox, and log into your VPN.


If you have other versions of Java or the IcedTea plugin installed, you are probably going to have problems. The two key points to note here are:

  1. Juniper VPN won't work with 64 bit Java, so whatever JDK you are working with, you need to make sure Firefox is using a 32 bit install of Java.
  2. Juniper VPN will work with OpenJDK, but see point 1.

You can switch between installed versions of Java using the update-java-alternatives program.

If someone would like to update this answer to explain how to run 32 bit Java install for Firefox plugins, but use a different install for everything else, please do!

  • I am on Ubuntu 15.04, are there any issues with running the OS using JDK 32-bit or would I need to switch back to 64-bit for any specific reason?
    – jerome
    Sep 26, 2015 at 12:57

The above solution is similar to another solution I answered here:

Running 32-bit Firefox with sun-jre in 64-bit Ubuntu

I do however still have an issue with Network Connect and Ubuntu's new way of doing DNS queries. I asked about this issue in a seperate post: How to prevent Juniper Network Connect breaking DNS resolutions

Not the answer you're looking for? Browse other questions tagged .