0

I'm attempting to follow this guide.

My display is 1600x900, however that resolution is not available in the Display Settings dialogue. I tried a few things, and ended up following the linked guide. I entered the following into the terminal:

$ cvt 1600 900
# 1600x900 59.95 Hz (CVT 1.44M9) hsync: 55.99 kHz; pclk: 118.25 MHz
Modeline "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync

$ xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  141 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  55
  Current serial number in output stream:  55

$ xrandr --addmode Virtual1 "1600x900_60.00"

$ xrandr --output Virtual1 --mode "1600x900_60.00"
xrandr: Configure crtc 0 failed

My display is, unsurprisingly, not set to 1600x900. Where have I erred?

Note that I'm running this in Virtualbox, and have never had this issue, on this machine, with Ubuntu or other virtualizations

1

Not a clue why, however I was able to solve the issue by simply renaming the mode. This worked:

$ xrandr --newmode "1600x900_60hz"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
$ xrandr --addmode Virtual1 "1600x900_60hz"
$ xrandr --output Virtual1 --mode "1600x900_60hz"
1
  • Interesting solution. I wonder if there was an incomplete mode setting somewhere preventing your first attempt 🤔 – user1091774 Jan 2 at 23:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.