2

I had been running the Backups program successfully in Lubuntu 18.04.3, in order to backup the Home folder to an external drive (which has plenty of space on it).

The Backups program worked successfully for several months. For the last 318 days now, though, the daily attempts of the Backups program to perform backups automatically have failed. And the Backup Now button is grayed out. (Since then until now, I was too overwhelmed to get engaged on this web site to try to get help to fix the problem.)

I am a relative newbie - and almost always I use GUIs. I can perform Terminal commands IF they are provided together with complete and precise instructions.

25
  • 1
    I booted up a Lubuntu 18.04.5 live system and didn't see any backup program (outside of rsync & terminal tools common to all Ubuntu systems), nor see any with packages.ubuntu.com/bionic/lubuntu-desktop (I suspect you've added it and it's not a default program). I'm guessing your external WD drive is NTFS thus non-POSIX (unless you re-formatted it) so as I don't know the program, and it's a foreign fs I'd explore as per my prior comment.
    – guiverc
    Commented Jan 3, 2021 at 10:00
  • 1
    My last comment probably won't help, as the exploration would likely have been unhelpful too (as really requires some IT/computer knowledge). If you open the file manager (pcmanfm) and navigate directory where you save your backups, and try to create (touch is the command, but you can right-click and Create New and select "Empty File" which is the touch command). Does this provide any clues? (ie. error messages). I prefer commands as the error messages are easier to see errors when they occur, a quick play with copy/paste & create-new (touch) both had errors visible & not visible
    – guiverc
    Commented Jan 3, 2021 at 10:13
  • 1
    To figure out the program, look at the Exec line in the Desktop Entry. You may want to grep -Ri backup /usr/share/applications to figure out which file it is. Then grep Exec /path/to/file.desktop to get the Exec line. That will tell us the executable. You can use which executable to find its path. And you can use dpkg -S /path/to/executable to find out which package provides it.
    – wxl
    Commented Jan 4, 2021 at 21:44
  • 1
    /usr/ is a special Linux directory, and is not related to "user" files in Linix (they are in /home/). help.ubuntu.com/community/LinuxFilesystemTreeOverview refers to "/usr" as "/usr contains the majority of user utilities and applications, and partly replicates the root directory structure, containing for instance, among others, /usr/bin/ and /usr/lib" I'm aware of Deja Dup but having never used it, I can't offer any advice sorry.
    – guiverc
    Commented Jan 13, 2021 at 1:40
  • 1
    Lubuntu links can be found at lubuntu.me/links which offer alternatives to this site. IRC allows real-time chat, and also long comment trails tend to scare off people at this site (they'll get moved to SE Chat, which those of using Ubuntu SSO [single sign on} to access this site cannot access, as it requires a login to Stack Exchange). Lubuntu being an official flavor too, means you can use Ubuntu sites (Deja Dup being a Ubuntu program, I'd expect faster/better results in #ubuntu for example than #lubuntu) wiki.ubuntu.com/IRC/ChannelList
    – guiverc
    Commented Jan 13, 2021 at 1:57

2 Answers 2

3

My thanks to guiverc for the helpful comments and links, especially yesterday. Accordingly, yesterday I read within Deja Dup`s "Back Up Now" button is not highlighted how I could un-gray the 'Back Up Now' button.

Specifically, yesterday I killed a process id (that is, a pid) for the backup program DejaDup. It was the pid of DejaDup that ended in ' --backup --auto '. After rebooting the computer I found that the 'Back Up Now' button was un-grayed. Then, I clicked the 'Back Up Now' button, and DejaDup started creating a fresh backup, and the reason it provided was "in order to avoid corruption" of the backup. However, after about 4 hours the backup attempt failed, and then the 'Back Up Now' button was grayed out again. Today I used the command line 'killall deja-dup', and once more the 'Back Up Now' button is ungrayed.

Via the website for DejaDup, wiki.gnome.org/Apps/DejaDup , I have filed a support request with the Gnome Infrastructure Team (at GitLab). Whereas DejaDup was updated on 13th January 2021 (according to the Software utility in lUbuntu 18.04.5), and whereas the aforementioned website for DejaDup was last updated on 25th August 2020, nevertheless this problem of grayed-out 'Back Up Now' button (and lack of a progress bar, by the way) is clearly over 8 years old by now.

1
  • In filing upstream (Deja Dup), you may not get much response as you're using an old version (older versions issues need to be tested & confirmed on the latest; currently in Ubuntu world that's hirsute 42.6 compared to your 37.1-2; (fyi: I'm on Lubuntu hirsute). Ubuntu only back-ports security fixes to older releases, not newer versions of software (unless it's more work to back-port security fixes only which is rare!). But THANK YOU for filing upstream, someone on a later release may test, confirm it & that's how attention is gained & fixes get done, so again thank you.
    – guiverc
    Commented Jan 13, 2021 at 22:17
0

Lubuntu 18.04 by default starts the Backup Monitor task which can cause the Backup Now button to be grayed out.

To disable the Backup Monitor task,

  1. Start Lubuntu and log in
  2. From the menu, select Preferences / Default Applications for LXSession
  3. Click Autostart at the left
  4. In the box at the bottom labeled Known Applications locate the item labeled Backup Monitor and untick its box

enter image description here

  1. Restart the computer, then log back in
  2. Plug your freshly prepared external backup media, formatted to ext4 and with a proper data partition created, into your system. Ensure that it is writeable by your user; use pcmanfm to create a dummy text file on it, then delete the dummy text fil.
  3. Start Deja-Dup, aka Backups.
  4. Configure Folders To Save and Folders to Ignore to meet your needs
  5. Select Storage Location and point to your external backup media
  6. Click Backup Now. A full backup will start.

Report back with details if any issues are encountered.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .